Welcome! Log In Create A New Profile


Extruder Problem... - Solved, sort of

Posted by Eddiie 
Extruder Problem... - Solved, sort of
April 25, 2016 10:42PM
So I just built a DIY Prusa I3. Actually got all the motors working on the first shot; can't believe it.

Anyway when it comes to finally printing, the filament will not extrude, the motor clicks...
I am able to feed filament through manually with little effort, it seems the motor should do it, too.

Are there settings in configuration.h or _adv that control the extruder's steps, torque, etc?

direct-drive. the common set up.


Edited 1 time(s). Last edit at 04/27/2016 07:30PM by Eddiie.
Re: Extruder Problem...
April 26, 2016 07:55AM
Sounds like insufficient current for the motor. What control board are you using. When we know what board then people can give guidance on how to adjust the settings. You should check them all to avoid issues with the other motors later.
Well done on getting this far.
make sure the threaded tube from the extruder isn't so far up as to hit the feed gear.
There are parameters in the firmware on the control board for the extruder steps. Again we would need to know what firmware you are using.
Re: Extruder Problem...
April 26, 2016 10:49PM
Yeah, sorry about that, it was late and am super tired.

I am using a RAMPS 1.4 board, Arduino 2560, Marlin, various versions.

Insufficient current sounds like a possibility and will investigate in a few minutes by either swapping out the driver or looking up how to work the pot.

Hope that is it.

Retract works fine.
Re: Extruder Problem...
April 26, 2016 11:02PM
Eddiie, I am having the very same problem. I have a ZoneStar P802M-A with V1.9 Firmware. I hope someone out there can help us.
April 27, 2016 07:35PM
I played around with the current settings on the stepper driver. It helped but did not solve the problem.
I also blew the 5a fuse on my RAMPS board by dropping the screwdriver as I was adjusting the pot.
Now it only works when plugged in to USB and +12. Pain in the butt to fix.

Anyway, what the problem turns out to be is that the heatsink that the fan mounts to was colliding with the gear on the stepper. Tightening the screws makes it happen. Loosening the screws stops the clicking and allows the filament to be extruded.

I also have an all metal replacement that arrived today. There is a couple hours of work here and maybe do a first print later tonight.

Hope this helps other people.
May 05, 2016 02:35PM
What a nightmare that turned out to be. lol
Not really sure where things went wrong but wound up replacing the Arduino, RAMPS, stepper drivers and the display. Something after dropping the screw driver inside while the printer was powered on (adjusting the current going to extruder stepper).
Maybe it was plugging in the RAMPS into my Arduino Due? Whatever it was, nothing worked, the mega got really hot when drivers were installed, no matter which driver, aarrghghhhhh for $30.00 replace everything and take an asprin.

During that time I also (had to) replaced the plastic direct drive extruding mechanism with a metal one, and using a bigger stepper motor, it has helped. The printer has printed many things and looks great. Still, get clicks every now and then, adjusted the current on the new drivers, with success (did not drop screwdriver into electronics this time).

Too much coffee!
Re: Extruder Problem... - Solved, sort of
May 11, 2016 12:49AM
Yeah I had that short problem. You most likely blew the 5v regulator on the Arduino board. It then only worked connected to the USB port. Used it for a bit that way and ended up blowing a MOSFET perhaps because the regulator was out of whack. So I just replaced the RAMPS and Arduino. If you want to adjust the regulators, take it off of the mains power supply and just keep the USB in. It's enough voltage to test it with a multimeter and not have to worry about shorting it with metal objects. I'm not sure if you used a multimeter to check the voltage, but it might not be a bad idea to see where you are exactly at.
Sorry, only registered users may post in this forum.

Click here to login