Welcome! Log In Create A New Profile


My x axis limit switch is not stopping the x axis when i x-home it (Tronxy X3A- P802M_8_V1.7)

Posted by Rasyoni 
I have bought a new board and try to auto level it and the printer y axis works fine but x axis moves towards the limit switch and don't stop.
Z axis comes to the corner and wont stop b/c the optical sensor is suspending freely and nothing there to block it.
Finally i cant get any driver to connect it to my PC (Windows 10).
Highly Appreciated your help.
With the Tronxy I'm guessing you have the Melzi V2.0 board. Not the best board in the world but will get the job done.

Without you listing what you have tried to get it to connect to windows, I'm just going to link you the Greetech wiki page about the board, there you will find driver instructions and download links. [www.geeetech.com]

Once you get the board connected, send it M119 to see what is happening with the x endstop, If you press down the x endstop and send M119, it should return with "Xmin: Triggered". If not then it might be something in the firmware that needs fixing, you have plugged in the endstop worng, or a dead endstop.

I dont understand your Z axis problem, maybe a pic to help explain the setup and problem
K my x axis limit switch is working now but the problem of himing z axis is because when i home it both x and y are at tge max corner ao when z axis desends downward and it gat thia 'optical senaor' as both at the corners it goes all the way down trying to break the bed. I attached the pic also.
Thanks all.
open | download - image-0-02-04-e2d434e33839df250bddffa350d8a824d17229a8efa43c4b7c2b2d72458b5f9d-V.jpg (241.7 KB)
If still confused by your Z axis issue.

From what I can understand you are trying to say that when you home the Z, Nothing touches the limit switch so it keeps moving?

If thats it then just move the optical sensor. When I asked for i pic I meant of the Z axis limit switch and issue so I could try and understand better
Re: My x axis limit switch is not stopping the x axis when i x-home it (Tronxy X3A- P802M_8_V1.7)
July 16, 2017 08:42PM
Its meant to do the following


There is a huge resource for this printer here [github.com]

You might want to update the firmware see [github.com]
According to the page the firmware supplied is really old.

Edited 1 time(s). Last edit at 07/16/2017 08:43PM by Dust.
@Dust thanks.
But when i tried to install the firmware i get this error message.

Arduino: 1.8.3 (Windows 10), Board: "Sanguino, ATmega1284 or ATmega1284P (16 MHz)"
In file included from sketch\SdFile.h:27:0,
from sketch\cardreader.h:8,
from sketch\Marlin_main.cpp:44:
SdBaseFile.h:38: error: using typedef-name 'fpos_t' after 'struct'
struct fpos_t {
In file included from sketch\Marlin.h:10:0,
from sketch\Marlin_main.cpp:30:
c:\program files (x86)\arduino\hardware\tools\avr\avr\include\stdio.h:950:33: note: 'fpos_t' has a previous declaration here
__extension__ typedef long long fpos_t;
exit status 1
using typedef-name 'fpos_t' after 'struct'

any idea?
open | download - error message Arduino.jpg (352.2 KB)
K I change the PC and now the error changed I have attached the error message.
Thanks All
open | download - 2017-07-20 (3).png (184.8 KB)
Re: My x axis limit switch is not stopping the x axis when i x-home it (Tronxy X3A- P802M_8_V1.7)
July 20, 2017 03:26AM
The first is a old firmware on a new arduino. They made the variable fpos_t a keyword and it now fails to compile on new versions.

Renaming fpos_t variables in SdBaseFile.h and SdBaseFile.cpp to another name like filepos_t fixes it fully.

The second is a bootloader issue, its ether not there or is configured differently from what the ardunio program expects...
The cause of this are numerous... most probably is the baud rate
In your error I see -b115200 but I suspect this needs -b19200

You need to find the boards.txt file that has the board your using (I think its in appdata in windows)

my boards.txt looks like
###### ATmega1284x

## Sanguino W/ ATmega1284 or ATmega1284P 16MHz
sanguino.menu.cpu.atmega1284p=ATmega1284 or ATmega1284P (16 MHz)


You need to change the line sanguino.menu.cpu.atmega1284p.upload.speed=19200

Then restart the ardunio as it only loads this file on startup
Thanks a lot now i managed to install. Thanks.
But now it says Err: MINTEMP
Also Attached a picture.
open | download - Err MINTEMP.jpg (287.7 KB)
Check your thermisters

Edited 2 time(s). Last edit at 07/21/2017 10:08PM by Roberts_Clif.
Thanks All.
Finally I managed to print my first gear.
@ Dust I will never forget your help it meas a lot.

One question tho: i printed my gear using repeaterhost and prontorface but the print quality is a bit poor even if i make the infill 100%. I attached the Pictures.
Is there good way to get a smooth surface and know what type of print setting i need to use for different types of model and which one is the best software i can use for slicing models.
open | download - IMG_20170724_074102.jpg (280.2 KB)
What settings are you using.
Sorry, only registered users may post in this forum.

Click here to login