Welcome! Log In Create A New Profile


2 Good years and now 60% size prints

Posted by Helihead 
2 Good years and now 60% size prints
February 10, 2018 11:24PM
Homebuilt I3 that has been running fine with lots of printing for the past two years. Last week it started printing everything a little over half size.

I figured the program got corrupted so I resent and retested. Same thing.

Put a new Mega and Ramps board plus all new drivers. Took time to carefully calibrate the current, retested and same thing.

Tried Cura 2.6.2, Slicr 1.33.8 and repetier 1.6.2 with several patterns included 25mm test cube.

All prints are about 60% in size in X, Y and Z. I checked the steps per unit and they are dead on.

Any ideas what this could be?


Re: 2 Good years and now 60% size prints
February 11, 2018 02:48AM
You've used a new Mega board too, but did you erase the eeprom before you flashed it with Marlin? After flashing the new FW, you have to send M502 & M500 to read the new parameters and store them in Eeprom.
Re: 2 Good years and now 60% size prints
February 11, 2018 11:20AM
I have swapped boards a couple of times since I built the printer and always just changed the values in Marlin before I uploaded the code to the board. I should go read to make sure things are the way they should be though for sure. You are right. The settings may not be right for some reason.
Re: 2 Good years and now 60% size prints
February 13, 2018 02:33AM
There is a sample program in Arduino IDE called "erase EEprom " or similar. I always run it, before flashing new FW.
Re: 2 Good years and now 60% size prints
February 13, 2018 08:08PM
OK figured it out and you aren't going to believe it. At least I didn't at first.

So the printer was printing a fairly large rocket nose cone when it stopped working (156mm round by 470 mm high) I modified my I3 specifically to be able to print fairly large ones like that.

After it flaked out everything was basically half size in all axes. If I tried to print that same nosecone it came in arond 178mm round by 235mm high. As I mentioned earlier, I reloaded the program, confirm the settings, changed mega, changed ramps etc and nothing worked. I said I also changed the 4 drivers but I noticed that I had actually used the same ones again by mistake. I didn't really think that was the issue but I swapped to the new drivers and it went to working correctly and all sizes were correct. I thought it was extremely unlikely that all 4 drivers had blown a bit exactly the same way so I swapped back to the original (bad) drivers... half size prints again.

I swapped over to the new drivers and all is good.

So, I'm not sure how it did it but mid print it blew the same input bit on all 4 drivers.

I now have a set of drivers that worked perfectly for probably 4 months and then suddenly started printing (as close as I can measure) EXACTLY half size prints. They seem to run fine except everything they print is half size and of course, I no longer trust them.

Never seen anything like it.

Thanks for the help trying to figure this weird thing out.

I'm up and running again, 1 hour into a 26 hour nose cone print...

Sorry, only registered users may post in this forum.

Click here to login