Z axis motors jamming
July 04, 2018 03:05AM
Hey Peeps
I am busy completing the build of my first printer, based on a Prusa i3, using Arduino Mega and Ramps 1.4 with Marlin.
I'm having problems with the z axis motors jamming when I try move them more than 1 mm at a time. If I unplug one of the z motors, the other runs perfectly, in both directions. The moment I plug both in, they make a horrible jamming noise if I move them in increments greater than 1 mm. They do this even when I remove the couplers and run them with no load, and adjusting the voltage from the stepper driver makes little difference. I have checked the micro-stepping settings and they seem to be correct.
It seems to me that the motors are interfering with each other somehow. Does it make any difference if the wires connecting one are longer than the others wires?
I am very confused, any help would be appreciated :/
Re: Z axis motors jamming
July 04, 2018 04:32AM
It sounds to me that you have insufficient output current from the driver. You can try turning up the current on the Z driver, but that may lead to the driver overheating.

What is the specification of the motors? Depending on that, you may be better off connecting the motors in series instead of in parallel.

Edited 1 time(s). Last edit at 07/04/2018 04:32AM by dc42.

Large delta printer [miscsolutions.wordpress.com], E3D tool changer, Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Z axis motors jamming
July 04, 2018 04:34AM

#define DEFAULT_MAX_FEEDRATE { 300, 300, 5, 25 }

The default setting for max Z feedrate is too high in the configuration.h if your using the 5mm threaded rods on the Z axis.

Change the 5 to a 2 and re-upload firmware

Edited 1 time(s). Last edit at 07/04/2018 04:34AM by obewan.
Re: Z axis motors jamming
July 04, 2018 07:22AM
Thanks obewan, it worked!
grinning smiley
Sorry, only registered users may post in this forum.

Click here to login