Welcome! Log In Create A New Profile


Want to upgrade electronics

Posted by rflournoy 
Want to upgrade electronics
February 11, 2020 11:40PM
I have a RepRapGuru Prusa i3. Last week I let my hot end get gummed up when our power failed, so I replaced it. Good news, I had an extra. Bad news, I tightened it up against the extruder gear. It clicked several times before I could hit "reset," and then the extruder wouldn't turn. I did all the troubleshooting things you do, and finally decided that the stepper drivers, RAMPS, or Arduino Mega may have blown. Since I had extras of each I decided to change them out, and verified every wire connector and connection. However, my Windows 10 computer won't recognize the new Arduino. I reverted back to the old Arduino and now the computer won't recognize it.

What are the suitable replacements for the Arduino Mega and RAMPS 1.4 that work with Windows 10?

Thank you for any assistance.
Re: Want to upgrade electronics
June 12, 2020 08:33AM
I have a RAMBo 1.3 on my RepRap Guru printer. running Marlin 2.0.5 seems to work well. I have another printer, Basically an original Prusa I3 MK2 on a folgertech frame running a Mini RAMBo and that is running PRUSA code

I like them both, the 1.3 has a few more features I might use at some point, but right now it works with the basics
Re: Want to upgrade electronics
June 15, 2020 11:10PM
Before replacing the board again, I'd do a bit of debugging. It seems unlikely that a gummed up hotend or overrunning a stepper axis would kill the controller board logic. It's also unlikely that a brand new board would be faulty. So the fault probably lies elsewhere.

First thing: is there power on your controller board? Is the power LED lit? It could also be that in the gumming up of the hotend, or the ungumming, the heater wires have got shorted out. Try disconnecting the heater wires from the control board. Possibly, if it was shorted out, your power supply is dead. Use a meter to check the voltage on your board.

If you have good power at the board and it's still not recognised, I'd try to check whether the board is communicating with the PC. Try swapping USB cables. Also look at the serial ports as reported by the PC, if you know how. (I'm not at my printer right now, so at the moment I can't walk you through how to check comms).

Get back to me with the results of the power supply check and we can talk about the next step.
Sorry, only registered users may post in this forum.

Click here to login