Welcome! Log In Create A New Profile


Z axis switch not working

Posted by Blisk 
Z axis switch not working
July 20, 2018 04:30AM
After uploading marlin 1.1.8 to my I3 printer and autobed levelling was already enabled Z axis switch doesn't work. I tested with M119 code and it say z_min: open
when I press z switch it say z_min triggered.
X and Y works OK.

I also noticed when I press Z home in repetier, on LCD shows this G28 Z forbidden
Can't find what can be wrong.
open | download - Marlin.rar (44 KB)
Re: Z axis switch not working
July 20, 2018 11:25AM
It sounds like your switch is working (your subject suggests otherwise)?

When you reset the printer and control each of the axis, do they move in the correct direction?

Have you tried setting the direction of your Z-axis the same as your other axis (in your Configuration.h file)?

Currently it is:
#define INVERT_Z_DIR false

Maybe make that true?

Sorry if my suggestions are not useful, I just had a quick look. On my old marlin FW (vs 1.1.0-RC7) I could not find the words "G28 Z forbidden". I am not sure if that is in the newer versions or a repetier thing.
Re: Z axis switch not working
July 23, 2018 05:25AM
I have disabled safe_homing_z now it works
Sorry, only registered users may post in this forum.

Click here to login