Welcome! Log In Create A New Profile

Advanced

Pwm fans...pulsing noise.Solution?

Posted by zonalimitatore 
Pwm fans...pulsing noise.Solution?
May 20, 2019 11:23AM
Hi at all.
I've change the stock fan with 2 fans.
The problem it's the noise generate by fans at low speed.
For explain it, it's like the fan receive a pulsating voltage at low frequency,and this cause a spin that induce the fan a vibration and cause the noise.

Maybe I can post a video to explain what i mean?
Re: Pwm fans...pulsing noise.Solution?
May 20, 2019 02:25PM
There's an option in the Configuration.h file ..

//#define FAST_PWM_FAN

Try uncommenting it and recompiling, see if it helps.
Re: Pwm fans...pulsing noise.Solution?
May 20, 2019 03:30PM
Ok I try to do it.
If I uncomment fast_pwm_fan, I have to comment fan_soft_pwm? (Now it's active)
Re: Pwm fans...pulsing noise.Solution?
May 21, 2019 04:04AM
no no, keep that if that's what you're using.
Re: Pwm fans...pulsing noise.Solution?
May 21, 2019 07:05PM
Ok.I've try.But it's the same....The fans pulsing
Re: Pwm fans...pulsing noise.Solution?
May 22, 2019 12:49AM
oh, hmmmm

Yes, try commenting out FAN_SOFT_PWM winking smiley

Edited 1 time(s). Last edit at 05/22/2019 12:52AM by Pippy.
Re: Pwm fans...pulsing noise.Solution?
May 22, 2019 06:56AM
Well....I try to eliminate fan_soft_pwm
There is less noise,but now I think I've work on pwm_scale and or dither,cause till 50% fans don't move

Edited 1 time(s). Last edit at 05/22/2019 07:11AM by zonalimitatore.
Re: Pwm fans...pulsing noise.Solution?
May 22, 2019 08:15AM
Solved.
I use only #define:

Fan_soft_pwm
Soft_pwm_scale 3
Fan_min_pwm 26 (cause at 0 fans don't spin)

Finally I've fans work well and without "pulsating noise" at every speed
Sorry, only registered users may post in this forum.

Click here to login