Welcome! Log In Create A New Profile


Marlin Rumba Z Calibration problem.

Posted by Markal 
Marlin Rumba Z Calibration problem.
December 30, 2019 10:12AM
Greetings to all. I am hoping some one might be able to assist with an issue I have been battling for 3 days over. Mr Google does not seem to be willing to give up the answer and I am just making things worse the more I try to fix it.

I have built S.T.E.V.E. a COREXY from Thingiverse and very well documented I thought in the main on Youtube. [www.thingiverse.com]

I did ask for some assistance from his Youtube channel in October but never got any response so I assume he has moved on from that so I am not able to ask him any question directly, but surely my problem has to be a fairly simple calibration issue that I am messing up royally and making it worse the more I try to fix it. So I decided it was time to ask for help.

The designer used a Ramps Board with DRV8825 drivers, but when my first run nose dived straight into the heated bed it blew my Arduino Mega and as I have lots of Ramps boards but no more Arduino Mega boards, I dusted off a Rumba board I tried to use on a laser project.

I am therefore now using a Rumba board with 5 x DRV8825 drivers and apart from changing the board description in Marlin from Ramps to Board_Rumba I have left most of the settings as he gave them.

RUMBA board has been set with all 3 switches ON under all the drivers as recommended for the DRV8825 so I have 1/32 stepping which I assume is the same as for the Ramps.

Driver Voltages, I have X Y and extruder set at 0.6v and Z at 1.0 (two motors) although it does work at 0.6. Nothing getting hot to the touch at this time but I have added a fan just in case.

Both Z motors turn easily by fingers when power is off.

I doubt these changes would make any difference but I did play around to get the fans to work so have changed Config_Adv and set Extruder_0_Auto_fan_pin to 8 (was set at -1 and hotend fan was not coming on)

I also changed Pins_Rumba and swapped E0 pins with E1 pins as I found I had a faulty E0 connector. but apart from that it is as the designer set it up;

Let me know if you need me to post the settings, and if so which.

I have both Z motors running from the Z connector wired in Parallel.

All motors home correctly, and Z is Positive as the bed lowers and is at 0 when the hotend touches the bed so the direction is correct.

I have followed the build instruction, Marlin Settings etc to the letter but my Z is just not right nor I suspect is the Extruder setting.

Printing the 20mm calibration cube - X and Y are fine, Z is out by a large factor.

I first tried the supplied Default_Axis_Steps_Per_Unit settings of 160,160,800,837.1 which the designer has his working at.

My printed 20mm cube came out at 3mm thick when I stopped it at the displayed 8mm level as it was drowning in melted plastic.

I reason that I was out by a multiple of .65 so I changed the Default_Axis_Steps_Per_Unit to 160,160,2128,837.1 and my cube came out as 20.5x20.5x13.4

Aha, I thought, I am getting there. I then changed Marlin to 160,160,3274,837.1

Now my steppers are as noisy as heck, sounds like a rattling bike. The cube tries to print, but now I have the hotend clogging each time I try to run it. It ran fine for about 2 layers then the hotend clogged up. I cleared it, but it did the same thing second time out.

The only difference now is that I have tried to slow the Z speed down, and I am guessing that is where the clogging started. I may have also knocked the Z limit but have reset that again.

I thought that the speed was down to the change in the Default Axis stepper Unit to 3274 so I slowed the Default_Max_Feedrate from 500,500,100,25 to 500,500,10,25 and the Default_Max_Acceleration from 2000,2000,50,10000 to 2000,2000,10,10000

Still the Z sounds like a rattling bike when it is homing, but quiet after that.

Am I messing with the wrong settings? what do I need to do to get the calibration correct. I am guessing I also have an over extruding calibration as well as a Z calibration setting. X&Y are both fine.

Any one able to shine a light on my problem please?
Re: Marlin Rumba Z Calibration problem.
December 30, 2019 10:34AM
Marlin has allways set the Z default max feedrate far to high in my opinion.
Default_Max_Feedrate from 500,500,100,25 to 500,500,10,25

Your on the right track here,
Try setting the Z feedrate to 2 or possibly 3
The accellration should be ok at 50.
Re: Marlin Rumba Z Calibration problem.
December 31, 2019 01:08AM
Thanks I will try that. Just got to unblock the extruder....again.

Will report back.
Re: Marlin Rumba Z Calibration problem.
December 31, 2019 04:09AM
I have had to rebuild the E3D. I found that there was no PTFE tubing inside.

After fitting a length of PTFE I got another jamb, I think because I was printing too close to the bed again. Need to improve the Z limit mount.

Dismantling again I found that the PTFE in the hotend had expanded right at the top just under the Titan extruder as there is nothing to fill the thread where the bowden tube would have screwed in. I have down loaded a Print version from Thingiverse [www.thingiverse.com] and will print it to see if that helps after sorting out the Z height. My guess is that this version is for a remote mounted extruder.

Will carry on trying.
Re: Marlin Rumba Z Calibration problem.
December 31, 2019 06:20AM
Press-fitting a bowden tube is not what you want. It decreases the inner diameter of the tube which can cause the filament to be pinched a bit in the PTFE tube. Normally an E3D hotend comes with a collet to grab onto the tube. I do not understand exactly what kind of setup you're using but it needs to be very well constructed in order to work well.

Re: Marlin Rumba Z Calibration problem.
December 31, 2019 08:58AM
Note to self. Stop chasing your tail. The extruder is not broken, it just will not run without the hotend being preheated.

I have set the Z feedrate to 3 as you suggested and acceleration back to 50

Eventually got things working again now with the required PTFE tubing in place.

Printed test cube and got almost the right result. 20x20x20.7 so out by a factor of 0.97

Have changed Z now to 3176 and printing another cube.
Re: Marlin Rumba Z Calibration problem.
December 31, 2019 09:44AM
Yay, Got it, spot on 20mm for the X.

Now to try and get the auto bed leveling to work as i do not trust this flimsy Z limit bracket just floating in mid air on the 8mm rod.

Thanks for the input.

Thanks Ohmarius, i only saw your input now. The 3d printed 'plug' I made sits just inside the top of the E3D (Clone) and I am guessing this was missing from the original design as it allowed the PTFE to swell and the filament to bunch up. It is not a press fit but screws nicely into the threads where the missing original bowden connector would have gone The new 'plug' then accepts the PTFE in the 4mm hole in the middle which then goes all the way to the heatbreak as it should. I am guessing that it should have come with the Hotend together with PTFE inside it.

Thank you for your valued input and guiding me in the correct direction. I was second guessing myself and chasing more than one problem.
Re: Marlin Rumba Z Calibration problem.
December 31, 2019 09:45AM
I dont know how to mark this as solved or if I need to.
Sorry, only registered users may post in this forum.

Click here to login