X / Y Homing fails ONLY using LCD (endstops / directions OK) (Marlin 1.1.0 to 2.1.0)
November 09, 2022 06:18AM
I've got a MTW MiniMax that used to be running Marlin 1.1.0 with a generic (Chinese knockoff) REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER.

Everything used to work correctly with 1.1.0.

I'm in the process of upgrading to Marlin 2.1.1. New firmware flashed, logo appears on LCD.

Using the LCD I can manually move the X / Y and Z axis in the correct direction (MIN is towards zero) towards my endstops. M119 from Pronterface shows that the endstops trigger when I push them correctly, etc...

I can successfully home the Z axis from the LCD, works great.

If I try to home the X or Y axis, it hits (and triggers) the MIN endstop, but does not stop moving the SERVO! (I have to remove power).

If I unplug the LCD screen and use Pronterface....everything works great, X/Y and Z homing all work great! (But the AutoHOME or individual axis HOME on the LCD don't work, they go towards the min endstops, and they keep going for
X and Y (but do home Z correctly).

The home direction of all three axis is set to MIN, and servos drive them in the right direction with zero towards the endstops.

So my question is....homing from Pronterface works great....but not the LCD...what configuration setting do I need to tweak to make that work correctly?

I was able to solve this issue. I'm not 100% sure what fixed it...but the last thing I changed before things started working was to enable the #EEPROM option in the firmware. When the board booted up, it asked to initalize the EEPROM, and after that, everything worked. (So perhaps it was using EEPROM settings from the 1.1.0 firmware, even though #EEPROM was not enabled???)

I had also changed several other configuration options, most notably setting up the pin for the extruder fan so that it would auto-enable when reaching 50 degrees, but my money is on enabling EEPROM.
Sorry, only registered users may post in this forum.

Click here to login