Ender3 v4.2.7 BIQU v2 microprobe setup?
October 04, 2023 07:40PM
HI all,

I'm trying to configure marlin for a BIQU v2 microprobe on an ender 3 with a v4.2.7 board.
I have made my way through the "MicroProbe V2 user manual" and I think I have marlin all configured correctly.
But to be honest I don't really have a clue what I'm doing.
The manual shows how to connect the probe on various BIQU boards, under each board is some custom info/code, can anyone explain to me what this is? and how I can apply this info to the Creality v4.2.7 board?

Is it just custom start gcode? or do I need to create a macro file or something?

Github BIQU microprobe V2 user manual

Printer Hardware:-
Original Ender 3 (2018 model)
Creality v4.2.7 board (TMC2225 driver's)
BIQU v2 microprobe
BMG clone extruder (direct drive)
Re: Ender3 v4.2.7 BIQU v2 microprobe setup?
October 04, 2023 09:59PM
connection wise, it is identical to a bltouch, ie you plug it into the 5 pin probe port.

The manual provided code is the config file for the probe for klipper firmware

An example Marlin config is in the manual..

this should work on a creality v4.2.7 on bugfix-2.1.x

//#define Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN // make sure to comment this out

and adjust this for your hardware
#define NOZZLE_TO_PROBE_OFFSET { 10, 10, 0 }

Edited 2 time(s). Last edit at 10/05/2023 06:52AM by Dust.
Re: Ender3 v4.2.7 BIQU v2 microprobe setup?
October 05, 2023 07:31AM
Hi Dust,

Thanks so much for clearing that up.

When setting:-
Should I also set:-
I seem to remember they both needed to be set to the same state in older versions of Marlin?

Also, should I change:-
#define SERVO_DELAY { 300 }
from 300 to 500?

As far as start gcode goes, do I just add a G29 after the G28, like the BL and CRtouch?
Re: Ender3 v4.2.7 BIQU v2 microprobe setup?
October 05, 2023 09:24PM
SERVO_DELAY is for servos, (or things emulating servos)

your probe only uses a enable/disable io signal. not servo control.

So SERVO_DELAY is not used here.
Re: Ender3 v4.2.7 BIQU v2 microprobe setup?
October 06, 2023 10:43AM
Ah I see, thank you!

I've compiled and flashed the firmware to the printer.

But I'm having a problem during homing:-
The probe deploys and retracts 3x on start-up.(probe stays blue no sign of a red led during start-up test)
Z goes up by 5mm, X and Y both home correctly, the printhead moves to the centre of the bed, Z goes up by another 5mm, probe deploys, Z goes down 10mm and stops.
Display reads:- "Homing Failed: PRINTER HALTED"

The printer seems unable to go below the initial Z start position.
If I trigger the probe as the the Z does its 10mm decent, homing appears to complete.

Also the probe isn't behaving as I expected it to from watching this video:-
(at about 7:50 during the video)
Stacking Layers Youtube video

In the video when the probe deploys a red led comes on, I don't get a red led when the probe deploys it just stays blue.
Also in the video when the probe hits a surface it measures with zero detent and retracts shortly after, when my probe hits a surface the probe instantly retracts into the body.
I fear this may be registering a crash state rather than actually measuring the position of the surface.

Edited 1 time(s). Last edit at 10/06/2023 06:31PM by Plecc.
Re: Ender3 v4.2.7 BIQU v2 microprobe setup?
October 06, 2023 02:23PM
Some of the things that could cause this:
  • Check the setting of Z_PROBE_LOW_POINT. It should be lower than the M114 results when leveling is disabled and the nozzle is touching the bed.
  • The probe is always triggered. Use M119 to check that it reports the probe as open when it isn't triggered.
Re: Ender3 v4.2.7 BIQU v2 microprobe setup?
October 06, 2023 07:22PM
Hi Bob,
Thanks for the feedback.

Z_PROBE_LOW_POINT is set to -2
M114 reports nozzle at zero.
I checked MIN_SOFTWARE_ENDSTOP_Z and it is enabled, should it be commented out?

If the probe is retracted M119 reports:-
x_min: open
y_min: open
z_probe: TRIGGERED

if the probe is deployed M119 reports:-
x_min: open
y_min: open
z_probe: open

Is the "z_min: TRIGGERED" the problem? I have the original Z limit switch completely removed from the printer, I should have mentioned this previously!

Or is z_min: just ignored now that Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN is disabled and USE_PROBE_FOR_Z_HOMING is enabled?

Edited 1 time(s). Last edit at 10/06/2023 07:37PM by Plecc.
Re: Ender3 v4.2.7 BIQU v2 microprobe setup?
October 06, 2023 07:30PM
Yes, MIN_SOFTWARE_ENDSTOP_Z should be commented out.
Re: Ender3 v4.2.7 BIQU v2 microprobe setup?
October 06, 2023 08:04PM
Thanks Bob,

I have commented out MIN_SOFTWARE_ENDSTOP_Z and re-flashed the firmware.
But unfortunately no change.

Do you think I may have a wiring issue or possibly a faulty probe?

Edited 1 time(s). Last edit at 10/07/2023 08:04AM by Plecc.
Re: Ender3 v4.2.7 BIQU v2 microprobe setup?
October 07, 2023 09:39AM
I thought I should check the wiring and connections again.
So I removed the board and probe from the printer while leaving all the wiring connected, then I did a continuity test between the pins on the board and the corresponding pins on the probe, all appears to be connected correctly.

I'm really puzzled as to why I don't see a red led when the probe deploys? Every video I have seen of the probe in action shows a red led inside the probe body, that turns on when the probe deploys and goes out when the probe is triggered.
It makes me think that the polarity for the red led must be reversed?
Re: Ender3 v4.2.7 BIQU v2 microprobe setup?
October 07, 2023 05:55PM
I think I may have figured it out, fingers crossed!

I have attached a wiring diagram for the v4.2.7 board.

I found a few other posts of people having similar problems with the v2 microprobe and other boards, all appeared to have the probe connected to a dedicated BLtouch port.
Most appeared to fix their issues by moving the microprobe trigger wires to the z min endstop pins.

In the microprobe manual there is a small section where it states:-
"For the V2 version, the detection signal line requires a strong pull up"

Looking at the wiring diagram for the v4.2.7 board there doesn't appear to be any 10k pull up resistors between the CPU and the trigger of the BLtouch port.
But the Z min pin does appear to have a 3.3v 10k pull-up circuit.
What do you both think, is this the problem?

I would have tested it already but I'm not 100% about the firmware changes to change to the z min pin.
Is this all I need to change?


Changed state from high to low


#define USE_PROBE_FOR_Z_HOMING // should this still be enabled?

Changed to pin PA7
#define Z_MIN_PROBE_PIN PA7 // should this still be enabled?


open | download - Creality.4.2.7.-.Schematic.28-5-22-1.pdf (193.7 KB)
Re: Ender3 v4.2.7 BIQU v2 microprobe setup?
October 08, 2023 04:59AM
I agree on the 10K pull up. The STM32Fxxx pullups are in the 30k - 50K range so switching to the Z_MIN port makes sense.

Yes, Z_MIN_PROBE_PIN should be disabled.

I think you have the remainder correct.
Re: Ender3 v4.2.7 BIQU v2 microprobe setup?
October 14, 2023 10:34AM
That did it!

Thanks Dust & Bob.
Its all working perfectly now, consistent & immaculate first layers on a dished heat-bed.

The probe isn't behaving exactly the same as the one in the video, linked in a previous post.
I still don't see any red LED when the probe deploys and it measures with a small detent, I guess the one in the video may be a v1 microprobe.

Thankfully the microprobe is completely silent while stowed unlike the POS CRtouch!
I previously fitted a Creality CRtouch, which also worked really well, but it had one enormous design oversight. The metal probe pin is quite large and and has a sloppy fit in the metal solenoid body. There also isn't any nylon guides for the pin, this allows the pin rattle against the solenoid body, all the timesad smiley
I tried quite a few things to quieten it down, but ended up sending it back due to the constant rattling.
Such a shame! Apart from the rattling and the large size the CRtouch is a great probe.

I'm so happy with the v2 microprobe that I'm tempted to fit another to my other ender! the only downside of the microprobe is the short cables supplied with the kit, I had to extend the cable by 150mm to fit the ender3.

Thanks again guys!
Re: Ender3 v4.2.7 BIQU v2 microprobe setup?
November 14, 2023 02:37AM
Can anyone help me out with the firmware for Marlin using the BIQU Micro? I have the sonic pad and just received my Rasberry pi 4 today actually but I’m not quite ready to set all that up because I have some prints I’d like to make first with a custom enclosure for my Rasberry Pi and buck converter. I don’t exactly know how to operate my printer without the auto bed leveling enabled (or attached) or know even if I can make prints using the firmware thts on it now with the CR touch. My printer came with a CR touch but I accidentally broke it while remounting it. So I ordered this probe and don’t understand fully what to change in marlin’s firmware. I have VS code opened up with Platformio along with the newest version of marlin. And starting out when I tried doing a quick build to see if it would build correctly after changing the “default_evens” from mega2560 to melzi, but the build fails without changing anything else. So I left it saying mega2560 and then the build succeeds. This is far as I’ve managed to go. I just need to know exactly what to change in marlin including the “default_evens”? Unless anyone can provide the firmware for a Ender 3 Neo tht came with CR touch with adjustments in getting the BIQU working properly? Please guys , I really need some help with this. I’d greatly appreciate it. My goal after printing my custom enclosure is to get kipper installed and I think I’d like to run Fluidd . Thank you guys.
Re: Ender3 v4.2.7 BIQU v2 microprobe setup?
December 05, 2023 02:44PM

I tried to follow everything you guy did to get the microprobe v2 to work on a creality board in Marlin. I am still not getting it to work on mine. Is there any way you could send me your config file so could compare the two of them?
Sorry, only registered users may post in this forum.

Click here to login