Welcome! Log In Create A New Profile

Advanced

Error when trying to load extruder firmware

Posted by ata0921 
Error when trying to load extruder firmware
January 17, 2011 06:21PM
I am trying to load the RepRap firmware onto my extruder board but I get the following errors.


Extruder.cpp: In function 'void setup()':
Extruder:35: error: 'Serial' was not declared in this scope
Extruder.cpp: In member function 'bool intercom::talk()':
intercom:55: error: 'Serial' was not declared in this scope
Extruder.cpp: In member function 'void intercom::tick()':
intercom:176: error: 'Serial' was not declared in this scope
intercom:210: error: 'Serial' was not declared in this scope

What can I do to fix this?


- Andy
digifabindustries.blogspot.com
Re: Error when trying to load extruder firmware
January 18, 2011 03:08AM
Did you select the correct processor type?

Arduino Diecimila or Duemilanove w/ ATmega 168


Bob Morrison
W├Ârth am Rhein, Germany
"Luke, use the source!"
BLOG - PHOTOS - Thingiverse
Re: Error when trying to load extruder firmware
January 18, 2011 03:23AM
Yeah, right processor type and serial port...

Turns out that using an older version of Arduino fixed it tho. I was using Arduino 22 and getting the above errors. When I used Arduino 21, it compiled/uploaded without a hitch.


- Andy
digifabindustries.blogspot.com
Re: Error when trying to load extruder firmware
January 27, 2011 06:04PM
I'm having the same problem. where did you find ver. 21 of the software?? and I was able to place the firmware in the motherboard with ver 22 so does this need to be redone also ??

thanks

Edited 1 time(s). Last edit at 01/27/2011 06:05PM by HereIgoAgain.
Re: Error when trying to load extruder firmware
January 27, 2011 06:23PM
You can find the older versions of arduino off of the arduino.cc website. It is on the download page underneath the current version.

I too was able to load the motherboard firmware with Arduino22, but was only successful with Arduino21 for the extruder board. Not sure what changed between the two versions, but using both solved my problems.


- Andy
digifabindustries.blogspot.com
Re: Error when trying to load extruder firmware
January 27, 2011 07:49PM
here is the software download page [arduino.cc]

look at bottom of page for 'Previous IDE Versions'

here is a direct download to windows version 21
[arduino.googlecode.com]


here is a direct download to linux version 21
[arduino.googlecode.com]
Re: Error when trying to load extruder firmware
January 28, 2011 08:03AM
downloaded and ran arduino-21. Program compiled and downloaded without a problem. Thanks for the quick and spot on help. Off now to the next step, I'm sure I'll be back.
Re: Error when trying to load extruder firmware
March 20, 2011 03:07PM
Some time back, I was having trouble loading software for extruder. In this thread, ATA0921 suggested I go back a version (ie. Arduino 2.1 instead of 2.2 for the extruder. I did this and it worked fine. Now some time later I am trying to do this again...and I get errors suggesting I should choose the Sanguino board which doesn't seem to be an option in the 2.1 software....I'm confused as to why this worked the first time ?? any ideas ??
Re: Error when trying to load extruder firmware
March 20, 2011 05:56PM
Is that one of the arduino version that don't officially support the sanguino, so you have to download the sanguino add-on? (check the sanguino website: sanguino.cc )


--
I'm building it with Baling Wire
Sorry, only registered users may post in this forum.

Click here to login