I am trying to finally setup bed leveling for my printer and cant get the firmware to compile, because of the error in the title.
I am not able to attach the file so i guess i need some help getting it up here so you can look at it?

If you cant guess I am lost in all this.
Just because you cant attach the file doesn't mean you are out of luck, just means you need to type more information (A pain I know)

What bed levelling system are you using?
What firmware are you using?
What did you change in the firmware file? (i.e. I uncommented #define BLTOUCH)

Silly question but did you try good old google? does this question from last year help you? [forums.reprap.org]

Show the link of where you downloaded the Firmware.
Explain what hardware you want complied in the firmware, we will take it from there.
My eyes got crossed last night and I knew I didn't put enough info out here to get it all out on the table, but thanks for getting things and me started in the right direction.

I have a Arduino Mega 2650 and a ramps 1.4. I am trying to use a servo mounted switch to do the bed leveling. I was going to try the bilinear grid since my plate expands and contracts with heat. I know not the best situation but I have a DIY printer made out of wood and drawer slides. It currently prints fine but anything over 4 inches square it is high on one corner and low on the other. So want to level it and see if I can print upgrades for it to make the printer a little less difficult to print on.

I downloaded the current Marlin firmware at [marlinfw.org] The zip file for 1.1. I went thru configuration.h file and put my current steps and sizes and settings in it. When I tried uncommenting the bed leveling to add that I started to get the errors. I have no LCD....its got a problem with its contrast and I think I have to do the whole resistor thing to it. So I don't run a sd card. I connect to the computer and run it fine from there.

I tried the Google thing and didn't really come up with answers but links to fourms that didn't have the answer?

At work now and will try your link when I get home looks like it might have something to try for me.

Thanks guys for the help and I hope I have given you the info needed.
Again without knowing what you changed in the z probe section its hard to help.

Have you been through the marlin 1.1 wiki? some really good information there and some good instructions on how to setup the bed levelling [marlinfw.org]

I would suggest starting with a copy of your known working firmware without bed levelling then follow the steps in the wiki for the servo z probe
Sorry, only registered users may post in this forum.

Click here to login