TMC2130 Direct drive extruder issue
February 01, 2019 06:38PM
Hello Everyone,

I am having an issue with running my direct drive extruder on a TMC2130 driver purchased from filastruder. I have had it running with a DRV8825 driver with no problems. I calibrated the extruder with the drv8825 installed before putting in the tmc2130. The tmc2130 driver are spi connected on the original hardware pins. After installing the tmc2130 I tried extruding 100mm of filament to see if the calibration had changed. It extruded about 10mm and started skipping steps repeatedly. I have tried decreasing acceleration and jerk setting, increasing hot-end temperature, decreasing micro-steps from 16 to 8 to 4, increasing motor current from .8 ma to 1.1ma in .1ma increments. Stealth chop is disabled for the extruder. I was initially running the drivers at 12v and have increased to 24v. Ramps is running on 12v. Drivers are individually power by 24v on vm and ground pins. Nothing seem to stop it from chattering(missing steps). I am sure I must be missing something but can't figure it out. Any help would be greatly appreciated!

Here is a link to photos of the printer and configuration files:
3d printer information


Prusa MK3 clone
E3D v6 extruder (bought from e3d)
Heated bed
1.8 degree steppers
Ramps 1.6
Adruino Mega 2560 (genuine)
ATX power supply
24v power supply controlled by atx power supply
X axis drv8825-12v
Y axis tmc2130-24v
Z axis tmc2130-24v
E0 tmc2130-24v


Inland blue translucent pteg
temps tried 235-255
I have confirmed the accuracy of the temps with an omega hh-51 with type k thermocouple. within 1 degree C.


Marlin bugfix-2.0.x

Hopefully I have included all the info you might need. If not I'm sorry. Let me know if you need anything else. I am beginning to pull out what little hair I have left!

Thanks in advance,


Edited 2 time(s). Last edit at 02/02/2019 05:31AM by Krpepe.
Re: TMC2130 Direct drive extruder issue
February 02, 2019 03:07AM
Did you try adjust motor current? I don't know what the default microstepping is but you may need to set that as well. Did you configure it using spi? This chip doesn't appear to have external pins to set the stepping mode like A4988.

Kind regards

NFAN CoreXY printer:
Re: TMC2130 Direct drive extruder issue
February 02, 2019 05:26AM

Thank you for your reply! It appears I have missed some facts in my original post. The TMC2130 driver were purchased from filastruder. They are spi connected to the hardware spi pins. I am not using the software spi. I have adjusted from the stock marlin setting of .8ma in .1ma steps up to 1.1ma, no luck. You are correct that they do not use the jumpers under the driver. Those jumpers were removed before installing the tmc2130 and through the firmware I have changed the micro steps from the marlin setting of 16 down to 8 and then 4, still no luck. I have been fighting with this for about 2 weeks now. I am just wondering if anyone else has run across this and found a solution or if it just doesn't work on a direct drive extruder.

Thank you again for your time,

Edited 2 time(s). Last edit at 02/02/2019 05:33AM by Krpepe.
Re: TMC2130 Direct drive extruder issue
February 03, 2019 02:34PM
I think I may have solved my problem. Linear advance k value was set. Apparently you can't have linear advance set and do a 100mm calibration extrusion without it missing steps. Lesson learned!

The more you know about people, the more you love your dog!
Sorry, only registered users may post in this forum.

Click here to login