Welcome! Log In Create A New Profile

Advanced

help request, advice needed smiling smiley

Posted by kling3r 
help request, advice needed smiling smiley
January 28, 2011 02:51PM
hello everyone!

I'm currently using a mendel bot that's been built by a student about a year ago. The mendel has never fully functioned as has sadly never printed a complete part other then the tiny cup (slash thimble) with a horrible resolution.
There are several problems that i detect for which i'm seeking advice.

some technical specs:
GEN3 makerbot electronics
Stepper motor extruder
Stepper motor directly mounted on the extruder controller via the Hbridges

First off,
the electronics that the mendel is using are the GEN3 ones from makerbot. I currently flashed the eeproms with the FiveD that's on this website. With this firmware i'm unable to succesfuly print. My questions concerning the firmware - which firmware should i best use?

i looked at this section of the wiki: [reprap.org] and choose to use the FiveD on Arduino.
but i have to be honest and admit that i'm too stupid to figure out how to use it.
i'm unsure what exactly that i need to flash using the FiveD_on_arduino. Is it the motherboard firmware or is it the extruder firmware. I read through the various files (makefile, config.h) and i was more confused then revelated smiling smiley
so to sum up the above: what advice would other users give me when choosing a firmware and perhaps some short directions on how to do what?

I have previously flashed the chipsets with the makerbot firmwares, but that did not work at all.
i was able to move the X, Y en Z axis, but when it came to extrusion it was all over the place.
The stepper motor had a death rattle no matter what PWM i set in ReplicatorG.

The nema17 stepper motors that drive the axises tend to get really hot. Specificaly the X and Y motors tend to heat up so much you can burn yourself on them. I'm told that stepper motors do get hot, but these get REALLY hot.
I'm seeing on the stepper driver controller that X and Y also have the red light burning all the time. When i compare this to a makerbot - that one only has the red led burning when it is actualy in motion. The stepper motors (X and Y, when you touch them) feel like they are continously going on and off. It's a sort of clicking sound they make, however the axis isn't moving. Is this abnormal behaviour? does anyone have any experience related to this problem?
when i was working with the makerbot firmware on the electronics this problem didn't occur.

I'm sorry for the abundance of question, and perhaps ramblings that i consider to be questions winking smiley
but i have been reading allot on blogs and forums - also trying allot of things, but my knowledge and understanding only reaches so far. I'm at the point where i have to call in a friend for help smiling smiley

much appreciate any help anyone can provide!
thank you
Re: help request, advice needed smiling smiley
January 28, 2011 05:18PM
Ok I have about as much experience as you with repraps but maybe I can help.

This I think that this explains what you have to do.
[reprap.org]
[reprap.org]


I don't have a reprap yet as I am in the process of building one.
read everything there and I can try to answer your questions or hopefully someone more knowledgeable will jump in.

Best of luck,
Jeff Olijar
Re: help request, advice needed smiling smiley
January 28, 2011 07:21PM
Questions about the fived_on_arduino firmware are usually on the "firmware - experimental, borrowed, and future"[/a] but luckily, most people read all over the place.

I suppose the 5DON firmware is a bit on the experimental side, though people have been using it, it is less common.

This firmware is just for the main board. The gen3 electronics are a bit unique in having a separate controller that which does temperature monitoring and heater control. The extruder board also, of course, controls the extruder stepper, but from the perspective of the main board the extruder stepper is controlled by step/dir pins just like any of the other axises steppers. Some people have trouble getting the hbridge thing to work and end up buying another stepper driver board, and that works fine too.

As for choosing a firmware, I'm firmly of the opinion that you should use the fived_on_arduino firmware. It doesn't have segment pauses (better prints) and has a number of other features that should improve things. Also, we need more guinea pigs, so you'd be contributing to reprap development. OTOH, it doesn't currently support endstops and homing. My
hacked version does, but also lacks some improvements and bug fixes that the main branch has. Please ask for help, you'll get it.

You DO need the modifications listed on this page for the extruder stepper to be controlled from the main board. If you've had the "official" firmware working, you already have these changes done. If you've been using makerbot firmwares, these modifications probably have to be done still - you need the things listed under "Required wiring changes to use the reprap.org firmware"

Stepper motors are usually rated to run really, really, hot. see this page You can adjust the stepper's current via a little pot on the stepper driver board. Turning it down a little should result in much cooler motors.

Clicking even when not moving is a little unusual though. Turning down the current may help there too, as one of the (many) things that can cause that sort of thing is the stepper driver chip overheating and shutting itself off, and then turning itself back on a moment later. If that's the problem, turning the current down will help, as would attaching a heatsink to the driver chip on the stepper boards.

(edit: Added link to forum, corrected grammar)

Edited 1 time(s). Last edit at 01/28/2011 07:25PM by jgilmore.


--
I'm building it with Baling Wire
Re: help request, advice needed smiling smiley
January 29, 2011 04:54AM
Use the last released reprap firmware.

I would recommend turning ACCELERATION OFF and using Skeinforge to generate the gcode.

Turn the potentiometer on the X, Y and Z steppers all the way counter clockwise and then clockwise until it starts moving (assuming you have sent it the gcode to do so) and then just a little bit more. Purpose is to limit the current to what the need but no more.


Bob Morrison
W├Ârth am Rhein, Germany
"Luke, use the source!"
BLOG - PHOTOS - Thingiverse
Sorry, only registered users may post in this forum.

Click here to login