Re: RepRap 3DR Delta printer Released
November 17, 2013 02:28AM
Hi Dolphinboy

I used these scripts in Repetier Host :-

Script Gcode
1 g28 g0 f8000 x-58 y-34 z0 ;sends hotend to base of tower 1 (X) front left
2 g28 g0 f8000 x58 y-34 z0 ;sends hotend to base of tower 2 (Y) front right
3 g28 g0 f8000 x0 y58 z0 ;sends hotend to base of tower 3 (Z) rear
4 g28 g0 f8000 x0 y0 z0 ;sends hotend to centre of build plate

Just edit the scripts in the gcode tab in RH. It's much easier than manually jogging the hotend to the base of each tower for checking the Z height after each M666 adjustment.

Do one tower at a time. Home the hotend, send script x, measure gap between hotend and bed, adjust with relevant M666 command, home, script x, check, M666 do this until height above bed is 0.1mm then move to the next tower.

After changing the DELTA_SMOOTH_ROD_OFFSET in firmware send script 4 measure height (usually what it was previously) then send script 1, the height will have changed (up or down) keep tweaking DELTA_SMOOTH_ROD_OFFSET until the height after scripts 1,2,3 and 4 are all equal. Then just adjust MANUAL_Z_HOME_POS to bring the height to 0.1mm.

My hall boards have a trimpot too but it is really difficult to use these to accurately set the heights. M666 is much easier :-)

Re: RepRap 3DR Delta printer Released
November 17, 2013 03:40PM
Hi Andy,

Thanks a lot again for your help, I finally understood the process and was able to reproduce it... anyway I had to do 13 iterations from the real smooth rod radius dimension I measured with my micrometer till I get the XYZ and center at the same height.

One last thing it's not working for me is: I'm able to set:
M666 X-5 Y-5 Z-5
(using "-5" as example) but if I then run:
close Repetier Host and try a print with a SD (without connecting to the computer) it doesn't remember the M666 calibration.
The quick and dirty solution was to add my M666 calibration on the "start Gcode" section but I would like to save it directly in firmware or/and EEPROM... how it is archived?

Thanks again

PS - I have to upload some pictures of my built, it is a 3DR "Max" with a bigger printing area =)
Re: RepRap 3DR Delta printer Released
November 18, 2013 03:55PM
Hi Dolphinboy

It sounds like your EEPROM is disabled. Check that section in Configuration.h.

Re: RepRap 3DR Delta printer Released
November 18, 2013 05:20PM
I will, thanks
RepRap 3DR Delta Cover
November 20, 2013 03:16PM
Any update on the cover for the 3DR? I'd love to use it.
Re: RepRap 3DR Delta printer Released
November 22, 2013 09:33AM
I'm in process of building a 3DR - three of them. One if for me, one for a friend and I am planning on giving one for a Xmas gift - if it gets done in time. The first is assembled and printing - but not well yet. My converted CNC rounter printed all three sets of plastics, which came out very well. This is my first experience with a Delta and with Rumba electronics. My other machine uses Mach3 and separate temperature controls. After a difficult start I figured out how to get into Arduino and upload the Marlin firmware to the 3DR. I can operate the machine using Repetier Host software but still having similar problems with the LCD display as several others.

I can home the home the machine, set temps and run programs from the LCD, but whenever I try to "move axis" all three motors take off until the head crashes into one of the columns - unless I hit the e-stop button first. If I first manually position the head down to about mid position between the up-stops and the bed, then the LCD "move axis" will work but they operate each tower as X, Y and Z motors separately rather than as cartesian moves and they can only go one direction: down but not up. This all sounds the same as several others have experienced so I'm happy to hear it's a software issue and others, who previously had other Delta software already installed, are not experiencing. I would really like to operate the 3DR similar to my Mach3 machine: adjust the Z-zero to the bed with a piece of paper and then select a program to run. But currently, the LCD is useless for doing any positioning moves. It's good to know that the RichRap Marlin software is the source of the problem as pointed out by HaDe. Now I just need to find the solution.

I tried to upload firmware form Eric Zahm (sp) but my LCD went blank. I then stared to install Repetier firmware but when i saw all the setup steps I stopped and reverted back to Marlin. I downloaded AndyCarts code but had a different problem getting confused now smiling smiley I enabled eeprom and can now access those settings from within Repetier Host, but when I change any axis offsets it effects the cartesian positioning and not the individual motors: i.e. when I set the X offset to 10mm I get movement of the printhead 10mm to right of center and not the X tower individually moving as if offset from the endstop as desired.

I've managed to get the bed pretty level and print a few items. The quality is not great - still needs extruder tweaking. But I think now that if I can resolve the was the firmware is working setup will be much easier. I'll take the time to reread through this entire thread and then try again - thanks for all the tips.

Re: RepRap 3DR Delta printer Released
November 22, 2013 05:34PM
Your experience is exactly what I saw happening to mine in every aspect that you mentioned I have been at a standstill for over a week trying to figure it out my last iteration was to use ANDYs working profile and install that once i did that all my motion motors seemed to be operating as they should but may still be incorrect as I am not used to how the delta printers are supposed to move but I can controls movement form both the LCD and repetier.

The only thing in repetier that is acting funky is the hot end temp when I first power teh unit on I see the temp values for the extruder and the bed all is normal but if I reconnect or reset the boards when it comes back the extruder information has a new friend in the form of a string of numbers followed by the same data as listed for extruder 1 upon reset another new friend on and on. NO clue what is causing that.

The thing I am having trouble with is my extruder motor not matter what I do I can not get it to operate when I attach it to E0.

If I swapp the motor with the motor on Z it turns on and moves as the original z motor would so that tells me teh motor and the wiring to the motor is good
If I swap the polulu driver from say teh Y circuitry to the E0 circuitry the Y circuitry and motor still work fine so that tells me the polulu is fine E0 is still dead with the working polulu form Y
So it is pointing to the E0 circuitry or maybe some setting that is not set correctly that is stopping E) form working
Re: RepRap 3DR Delta printer Released
November 22, 2013 05:55PM
Tesseract, I had the same problem initially with the extruder motor not working. It was firmware disabled because the temperature was not up the the minimum. There's a setting min temp and mine is set at 165 degrees. Once the print head is above that. E worked fine. I did as you did, swapping the E motor to the X drive and it worked; then I noticed a message in Repetier Host saying something like "below min temp". The min temp setting might be in Repetier but I thing it is Marlin.

Thanks for the info on Andy's firmware. I'll give it another try.

Re: RepRap 3DR Delta printer Released
November 22, 2013 07:56PM
I thought about that but I brought the extruder temp up to I think about 180C so it should have kicked on but I will double check that as well
Re: RepRap 3DR Delta printer Released
November 23, 2013 08:02PM
Well, I downloaded AndyCart's firmware again - made sure I got it right this time and now it's a different machine. The axis now move in cartesian coordinates. All of Andy's numbers are wrong for my machine but I can fix that. It's amazing how differnet the LCD panel is - even the beep sound is differnent; and there's a power off function that didn't exist before.

Anyway I'll start calibrating again and see how it goes. I've spend several hours trying to get the bed level before. I can get it withing 0.001" at all three columns and in the center. Afterwords, 50mm linear movement in +X, -X and +Y are withing 0.002" or so, but when I move to 50mm -Y, the bed is off 0.010 or more. Really frustrating. Oh well - try again. At least now the LCD moves appear as they should be so my result may be better. Thanks Andy.

Re: RepRap 3DR Delta printer Released
November 24, 2013 05:00AM
>> but when I move to 50mm -Y, the bed is off 0.010 or more.<<

Other than mechanical problems (slop in the linear bearings or rod connectors, drive filament not REALLY tight, etc.) it might be a warped bed - this is what I found with mine too. Also, slightly warps or other tolerances in the plastic parts (remember those were made with simple and usually not perfectly calibrated 3D printers, too ;-)) could well add up to cause those Z variances. All of this results in (roughly) +/- 0.2mm Z variations mainly at extreme radius positions far away from any of the towers (for example 0, -80, 0). Only the inner, say, 50 mm radius looks better with 0.1mm max.

I'll see if I can find a better glass (or carbon) bed, preferrably ground flat - the rest of tolerances I fear we have to accept, or implement a Z probe like Johann's.

As for this LCD problem which can be found in ALL Marlin versions I examined:

>> It randomly shows , + ' *. (- etc, single character at a time instead of the correct X or Y position i.e a number <<

The problem is that the X/Y display function works only for positive numbers - a bug which is of course not apparent on normal (cartesian) printers which (usually) never move to negative X/Y positions.

Look for the following in ultralcd_implementation_hitachi_HD44780.h around line 463:

lcd_printPGM(PSTR(" Y"));

Change "ftostr3" to "ftostr30" and implement a new function somewhere in ultralcp.cpp (I suggest somewhere around line 1298, depending on the version you have):

//  convert float to string with +123 format
char *ftostr30(const float &x)
  int xx=x;
  return conv;

Also add the prototype to ultralcd.h:

char *ftostr30(const float &x);

This fixes the problem while not breaking the display for cartesian printers. Probably someone might want to have this fix pushed to the Marlin repository (don't have the time for that right now, sorry).

There are more fixes in ultralcd.cpp with lesser importance - to correct the display of Z Jerk and Z steps per unit for Deltas:

#ifdef DELTA
    MENU_ITEM_EDIT(float3, MSG_VZ_JERK, &max_z_jerk, 1, 990);
    MENU_ITEM_EDIT(float52, MSG_VZ_JERK, &max_z_jerk, 0.1, 990);

#ifdef DELTA
    MENU_ITEM_EDIT(float52, MSG_ZSTEPS, &axis_steps_per_unit[Z_AXIS], 5, 9999);
    MENU_ITEM_EDIT(float51, MSG_ZSTEPS, &axis_steps_per_unit[Z_AXIS], 5, 9999);

As mentioned those are just cosmetic fixes :-) - this printer should work just fine without them.
Re: RepRap 3DR Delta printer Released
November 24, 2013 05:07AM
BTW I took a chance with Repetier firmware last week (latest development branch as of 2013-11-20), found it to work fine in general BUT experienced problems with lost steps on longer prints from SD card. Anyone got Repetier firmware working reliably yet (and if so, which version)?
Re: RepRap 3DR Delta printer Released
November 24, 2013 12:09PM
Yes, I am working with repetier firmware and it looks good so far....After discovering the wrong microstepping jumpering on the board and solved it, went directly ahead with repetier firmware. I prefer this firmware because it works better with repetier host software.

Now I have solved the firmware issues, the host software configuration and the electronic issues, I still have one mechanical problem.

I couldnt built perfect diagonal rods, that are identical in length, because of the bad quality of my printed joints. I am still looking for assembled Rods with Traxxas Rod Ends and the correct length. Found them but in USA...not yet in Germany. So I will start calibrating, only after resolving this last problem.

Actual video of my build
Re: RepRap 3DR Delta printer Released
November 25, 2013 06:23AM
Is there any news on when the 4th Tutorial will be posted? I'm eagerly awaiting reading it smiling smiley
Re: RepRap 3DR Delta printer Released
November 25, 2013 06:41PM
As RichRap says "Part 4 very soon". smiling smiley HaDe thanks for the tips on the mechanical side. I've been using a piece of 1/2" cast aluminum tooling plate for checking calibration. It's spec'd at 0.005" per foot flatness for the the size of the 3DR it should be withing a couple mils. None, the less I check everything and found my plate to be rocking a bit so I glued sandpaper to one side and worked on knowing off the high spots on the 3DR base. I also found I was using a differnet style ball link on the dial indicator holder and this was causing the diagonal rods to be slighly out of parallel with the tower slides. So after making those changes I started again using the M666 command for setting the offsets. I also decided to use a 100mm base circle for all measurements and when I got done everything was withing about 0.1mm (4 mils). If I push the center out beyond a 50mm radius, the flatness gets worse. At least now I am printing some pretty decent parts and can start learning how to operate the machine and see what slicing parameters it likes.

One question: is there a way to set the offsets created using the M666 command back into the Marlin firmware file? It appears that whenever I change something in the firmware and re-update the machine, those offsets are lost.

Thanks for all the tips.
Re: RepRap 3DR Delta printer Released
November 25, 2013 07:05PM
Hey guys still having issues with my mysterious extruders any ideas

Notice the status bar each time I re boot the firmware I get a new extruder
It seems like it is functioning correctly except the the boards does not seem to know what the temp is I can not get my extruder motore to start i heat the extruder to whewre it shows 180C and still no motion from the extruder motor
Re: RepRap 3DR Delta printer Released
November 25, 2013 10:45PM
Some additional data I saw some thing that caught my attention I uploaded firmware that was no to be good from my mac to my second printer and lo and behold I saw the numbers again on this printer and was confused because it was working previously just fine I also connected through arduino and the dev/tty. device and I saw the funky extruders I tried connecting to the dev/cu device and it all was normal I tried several times on the tty connection with the same firmware and it always gave me the funky extruder dev/cu. worked fine.

So I tried it using the same MAC and connection to the device I uploaded the firmware and what I see now is that it boots up correctly but it is giving me the 1 command waiting and what it is waiting for is the extruder temp this is through repetier host it just waits for the extruder temp the weirder part is that I see the temp and can control the extruder temp with the LCD

I am not sure if the funky extruder issue is gone now in repetier because I have yet to see it get the extruder temp

Still hoping for some ideas
Re: RepRap 3DR Delta printer Released
November 28, 2013 03:10AM
Hi there

I have attached my 0.83 repetier firmware if it helps anyone. This is for a megatronics V2.0 and I have the LCD and Keypad working. This was modified from the Rostock Max firmware. Note that I haven't actually printed anything yet as I am still waiting for my E3D hotend but I have done many hours of dry runs. You will obviously need to adjust the Z-height.

On the LCD while printing, it displays Mul: 100 Buf 16. The mul is the speed multiplication and I assume that Buf stands for buffer but what does the 16 mean?
Has anyone managed to get megatronics to print from the SD card without the USB cable attached? As soon as I pull out the USB cable, I lose power.

open | download - (210.4 KB)
Re: RepRap 3DR Delta printer Released
December 01, 2013 04:43PM
Hello guy's

Ive been working on the 3DR aswell ( [] ) *dutch*

It seems im stuck on the firmware.
ive tried Richrap's firmware and the one AndyCart posted on page 6
The AndyCart version works better , as far as "working" is meanng full.

Both versions are going for the endstop's and react to that.. , AndyCart's version reacts on the Z on the LCD but not the amount as it tells me on the LCD
ive been changing the steps but is doenst seem to do any thing on the moving in mm , its still doing the same movement

A dry print run result n crashed.
ive been digging for day's now.. so it time to seek for 3DR help.

edit, im on a RAMPS 1.4 from RRdiscount

Edited 2 time(s). Last edit at 12/01/2013 04:45PM by HeAdWaVe.
Re: RepRap 3DR Delta printer Released
December 02, 2013 12:07PM
Did the guy who made the 3DR "extensions" for a bigger build platform release his files? I was having trouble finding them.
Re: RepRap 3DR Delta printer Released
December 02, 2013 12:37PM
i got some for you
Re: RepRap 3DR Delta printer Released
December 02, 2013 01:00PM
Hi Tomek,

I don't know if you refer to mines... anyway, I have just uploaded them:

I still need to document the whole process and what other changes I made to the original RichRap version but basically you can use these 2 parts.
Re: RepRap 3DR Delta printer Released
December 02, 2013 02:33PM
Very nice aswell.

But please someone help me on a working firmware

Edited 1 time(s). Last edit at 12/02/2013 02:48PM by HeAdWaVe.
Re: RepRap 3DR Delta printer Released
December 03, 2013 02:38AM
I don't know if mine will help you because I tweaked it so that I could use it with a Full Graphic Smart LCD display, anyway, I can share with you it or the configuration I used, that it, what I changed in "configuration.h" and "configuration_adv.h" in order to make it works...
Re: RepRap 3DR Delta printer Released
December 03, 2013 08:23AM
Hi All,

Part 4 of the 3DR build and tutorial is finally up - FIRMWARE, enjoy and do tell me what's missing for you

Lots of other cool stuff also discussed too.



Edited 1 time(s). Last edit at 12/04/2013 05:04AM by richrap.

Re: RepRap 3DR Delta printer Released
December 03, 2013 12:58PM
Thanks for the two responses with the extended 3DR files smiling smiley! (and richard for the most recent 3dr update)
Re: RepRap 3DR Delta printer Released
December 04, 2013 03:43AM
Thanks Richard. im diving in tonight!!

And thanks for sharing my Ramps design!

Edit, Richard, the link in your article to the Ramps adapterplate is not working! ( [] )

Edited 1 time(s). Last edit at 12/04/2013 06:21AM by HeAdWaVe.
Re: RepRap 3DR Delta printer Released
December 05, 2013 02:04PM
I got it working!!

it was in the Gcode!

now waiting for my hotend ( 0,35 - 1.75 )
Re: RepRap 3DR Delta printer Released
December 05, 2013 03:44PM
I am also having firmware issues what was it you got working and what was in the Gcode

I have something strange going on I built the 3dr following Rich's blogs but when I tried to use the firmware he had posted after doing a Home any movement started from the LCD result in the motors really freaking out to would move very rapidly and one would go slow causing the extruder platform to slam into the slow moving support piece.It works the same way form the computer

I have since tried Andy's working firmware install and it seems to much better after doing a home all motions functions seemed to work exactly as they should when controlled for the LCD however when I connect to the printer I make the connection and I see the firmware version and the last thing it seem to want is the current temp of the extruder and there it sits I cannot go further until that param gets loaded I show one command waiting I assume it is the get extruder temp but the funny thing is I see teh current extruder temp on the LCD and I can raise it and it goes up and it maintains and I can lower it but only from the LCD the computer is still waiting for the temp value to come in.

The other issue is that I can not get my extruder motor to operate at all I understand it is a temp thing and the extruder needs to be at a certain temp but even from the LCD when I raise the temp above the required temp still nothing. I really mean nothing.

I have to make an assumption at this point but I don't think I am supposed to be able to move the extruder motor at all once it is powered up. I understand that I can not move it right now for whatever reason via the computer but once it is powered on should it stay at least fixed in its current position this I do not know My motor moves easily by hand all of the time right now both when the printer is on or off. Is this the way it should work.

I have swapped out the cables and the polulu boards with no good ones and( the z motor and z polulu board) and the both work when connected to teh z circuitry but fail when on the E0 circuitry.
I also followed Rich's suggestion of making sure the amperage used by the motor was correct so that is not the issue

can just the E0 circuitry go out and leave the rest operational or do I still need look at something else

When I tried E1 I got the motor to buzz a little bit and maybe vibrate but that was all so I am not sure what that meant

I am trying all kinds of things but I need some direct help

Edited 1 time(s). Last edit at 12/05/2013 03:44PM by tesseract.
Re: RepRap 3DR Delta printer Released
December 05, 2013 06:14PM
Hi Tesseract

What is your esteps setting in config.h? If you are still using my value that may be your issue. I have 1/32 drivers so you would need to halve my value for 1/16 on Pololu., assuming you are using Rich's version of the Wade extruder with the herring bone gear.

Have you tired an M302 command to allow extrusion cold?

Sorry, only registered users may post in this forum.

Click here to login