Welcome! Log In Create A New Profile

Advanced

Kossel Delta xxl build project HELP

Posted by alex773 
Re: Kossel Delta xxl build project HELP
May 13, 2019 03:51PM
I unplugged the PT100 from Smart effector and plugged it back on and the temperature for Hotend now it is 26.5 C and the bed is 23.3 C. Now it is working good but I'm not sure where is the problem.
Re: Kossel Delta xxl build project HELP
May 14, 2019 03:26AM
You have about 5 ohms resistance in the wiring. Unless you have used very thin wires, there is a bad connection.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Kossel Delta xxl build project HELP
May 14, 2019 10:47PM
Thank you David for your response. Sorry for delay. I checked what you said and I found a bad connection to the daughter board. When I checked the daughter board with the supplied 100 ohm resistor I have a reading of. - 1.3 degree C. The wire for PT100 are 22 gauge in a 4-wires connection. Now I have 24.9 on the Bed and 28.7 on the Hotend. Let's hope it is all good now. Thank you
Re: Kossel Delta xxl build project HELP
May 19, 2019 11:15PM
I got the Simplify 3d software last week and I was trying to print something this weekend with no success. I Upload the G-code File and then I run it. When the printer it is ready to print the Hotend it goes crazy fast down and smash into the bed . I'm afraid is going to break the glass. Please advise what settings I should change in order to be able to print finally something.
Thank you
Re: Kossel Delta xxl build project HELP
May 20, 2019 12:31PM
That's almost exactly my first experience. It's because it's using the non print speed to move to where it needs to be.

One thing you will want to verify is your homed height. When I first set up my printer, I did this.
I set my homed height extra short, so it thought the nozzle was at Z0 when it really was about 10 mm or 15 mm above the bed.
Homed the printer, Heated it to 130C nozzle and 60C bed.
Moved the nozzle down until it stopped which should be 10 mm or 15 mm above the bed (but it thinks it's Z0)
Then I sent G2 Z20 (this would allow me to move the nozzle down past the "virtual" zero point I had set
Then I moved it down in 0.05 increments until i could just slide a piece of paper under the nozzle with some resistance

Then subtract position it thinks it's at in the web interface from 20
Then subtract that value from 20 and it will give you the amount it actually moved
Measure and add the thickness of the paper to that measurement

Then add that number to your homed height and you should be right on that measurement

I also dislike the really fast dive
I have my work flow as below.

1. Turn on printer
2. Home printer
3. Move nozzle to 5mm above bed at 30 mm/sec. (G0 Z5 F1800)
4. Warm up nozzle to 130C and bed to 60C
5. G30
6. G32

At this point I don't home it again, even minuscule differences on when the endstops trigger could change your calibration.

In my Slicer, I don't have any start gcode other than moving the nozzle to Y-150 and extruding some filament.
I know it seems logical to home the printer after every print with G28 but don't unless you want to calibrate it before every print.
I tell mine to go to X0 Y0 and Z whatever the homed height is minus 5

Edited 1 time(s). Last edit at 05/20/2019 12:57PM by FA-MAS.
Re: Kossel Delta xxl build project HELP
May 20, 2019 02:55PM
Thank you FA-MAS.
I set my homed height from 469 mm to 459mm, then I moved the nozzle down and it stopped 10mm above the bed. Then I sent G2 Z20 and I got this Error : G2/G3: missing I or J parameter . Should I send the M564 S0 to disable axis limits ?

Edited 1 time(s). Last edit at 05/20/2019 02:59PM by alex773.
Re: Kossel Delta xxl build project HELP
May 20, 2019 04:41PM
Oops, typo. it should have been G92

I don't like to disable axis limits, but I suppose you could do that and then just add whatever negative value it produces to the homed height.

Edited 1 time(s). Last edit at 05/20/2019 04:42PM by FA-MAS.
Re: Kossel Delta xxl build project HELP
May 20, 2019 05:31PM
Thank you FA-MAS. How can I lower the speed to move the nozzle down towards bed ( the speed right now it's crazy fast). What settings I have to change ? Thank you
Re: Kossel Delta xxl build project HELP
May 21, 2019 02:18AM
That’s why I send the G0 Z5 F1800, it’ll move it down to 5 mm at 30 mm/s rather than the max speed you set in config.g. You don’t wanna change that.
Re: Kossel Delta xxl build project HELP
May 21, 2019 04:42PM
Thank you FA-MAS and sorry for delay. I adjusted the homed height using the G92 Z20 . Do you have G0 Z5 F1800 in Bed.g before G30 and G32 or you send it manually after you turn on the printer ?

Edited 2 time(s). Last edit at 05/21/2019 10:59PM by alex773.
Re: Kossel Delta xxl build project HELP
May 22, 2019 10:35AM
I send it manually after I home the printer. I usually go like this.

1. Turn on printer
2. Home printer
3. Move nozzle to 5mm above bed at 30 mm/sec. (G0 Z5 F1800)
4. Warm up nozzle to 130C and bed to 60C
5. G30
6. G32
Re: Kossel Delta xxl build project HELP
May 22, 2019 10:27PM
This is my first print. I'm so happy. It's a bad print but it is a PRINT.
Attachments:
open | download - IMG_20190522_211702.jpg (215.5 KB)
open | download - IMG_20190522_210827.jpg (213 KB)
open | download - IMG_20190522_210655.jpg (207.2 KB)
Re: Kossel Delta xxl build project HELP
May 30, 2019 01:43PM
For the last two weeks I was trying to print and calibrate the printer . I have a problem with the extrusion. The print is working good for not more than 25% then the printer is printing with no filament. I don't know where should I look.
Thank you
Attachments:
open | download - IMG_20190530_121915.jpg (209.8 KB)
Re: Kossel Delta xxl build project HELP
May 30, 2019 02:00PM
Need more information. What extruder are you using, what stepper motor driving it, and what motor current have you set? What material are you printing, at what temperature? Are you getting any heater fault messages? After extrusion stops, what do you need to do to start it again?

Edited 1 time(s). Last edit at 05/30/2019 02:00PM by dc42.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Kossel Delta xxl build project HELP
May 30, 2019 02:55PM
Thank you David. I'm using the Nimble extruder with this stepper motor :[www.omc-stepperonline.com]
; Drives
M569 P0 S0 ; Drive 0 goes backwards
M569 P1 S0 ; Drive 1 goes backwards
M569 P2 S0 ; Drive 2 goes backwards
M569 P3 S0 ; Drive 3 goes backwards
M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
M92 X200.00 Y200.00 Z200.00 E2700.00 ; Set steps per mm
M566 X1200.00 Y1200.00 Z1200.00 E36.00 ; Set maximum instantaneous speed changes (mm/min)
M203 X18000.00 Y18000.00 Z18000.00 E1200.00 ; Set maximum speeds (mm/min)
M201 X1000.00 Y1000.00 Z1000.00 E120.00 ; Set accelerations (mm/s^2)
M906 X1000.00 Y1000.00 Z1000.00 E500.00 I35 ; Set motor currents (mA) and motor idle factor in per cent
M84 S10 ; Set idle timeout

I'm printing PLA at 200 degrees C. No heater fault messages. After extrusion stops I have to restart the printer , pull out the filament and then I have to reinstall the filament into the extruder and then try again.
Attachments:
open | download - IMG_20190530_135529.jpg (255 KB)
Re: Kossel Delta xxl build project HELP
May 30, 2019 05:34PM
How fast are you printing at 200C?
Your machine may be able to move fast, but the extrusion system may not be able to melt it at the same speed.

First I made sure the extruder was putting enough pressure on the filament, you probably don't have to worry about that on the nimble.

When testing I made a cube larger than the maximum speed i wanted to print which was 90 mm/sec.
The cube I made was 100 mm which should allow the moves to be large enough that it actually can reach 90 mm/sec

I sliced the cube at 100% infill at the lowest temperature and the lowest speed I wanted to go, 40 mm/sec. Then I printed it.

I observed the print and the extruder. If the extruder was not losing steps/slipping, I kicked up the speed slider 10 mm/sec

I observed for the same things again. When it started to lose steps/slip, I upped the temperature until it stopped. then I upped the speed again.

I did the same thing until I reached a happy medium between speed and temperature. I believe it was 60 mm/sec at 210C.

I did keep going, I was able to get it to print just fine at 90 mm/sec at 230C but that was supposedly outside of the filament's usable range. So I backed it off.

You may have to make those types of considerations.


My 3D Printing YouTube Channel
Better Living Through 3D Printing

Follow me on Instagram and Twitter
Instagram
Twitter
Re: Kossel Delta xxl build project HELP
May 30, 2019 08:58PM
Thank you blt3dp. Do you still have the STL file for the Cube ? I'm going to do this test but first I have to fix the extrusion problem

Edited 1 time(s). Last edit at 05/31/2019 01:06PM by alex773.
Re: Kossel Delta xxl build project HELP
May 31, 2019 09:46AM
The speed versus the temperature you're printing may be the cause of your extrusion stopping part way through a print. I'd say test as above to find the compromise between speed and temperature that your machine is happy with.

Of course make sure your extrusion is calibrated. When you command it to extrude 100 mm, it should pull that much into the nimble.

Also that particular print you've shown is one of those lattice cubes I'm guessing? That's basically a retraction torture test. Multiple retractions in a short time could cause a jam if your retraction isn't quite right.

Here's the cube, I wouldn't say allow it to complete but it's big enough to allow you to find that balance between speed and temperature.
100x100_mm_cube.stl


My 3D Printing YouTube Channel
Better Living Through 3D Printing

Follow me on Instagram and Twitter
Instagram
Twitter
Re: Kossel Delta xxl build project HELP
May 31, 2019 10:02AM
Thank you blt3dp. I will try to get it done tonight. Please guide me through this process. Thank you

Edited 1 time(s). Last edit at 05/31/2019 01:07PM by alex773.
Re: Kossel Delta xxl build project HELP
May 31, 2019 10:23AM
Maybe dc42 can chime in on this, but would you want to disable interpolation for the extruder? I know the nimble documentation says 1/16 microstepping, i dunno how interpolation would affect that.
You could also increase the motor current to your extruder to 800

Edit: It's FA-MAS, changed my username.

Edited 2 time(s). Last edit at 05/31/2019 12:08PM by blt3dp.


My 3D Printing YouTube Channel
Better Living Through 3D Printing

Follow me on Instagram and Twitter
Instagram
Twitter
Re: Kossel Delta xxl build project HELP
May 31, 2019 01:12PM
Ok FA-MAS , good to know. Thank you and I will try your recommendation tonight.
Re: Kossel Delta xxl build project HELP
May 31, 2019 03:58PM
Quote
blt3dp
Maybe dc42 can chime in on this, but would you want to disable interpolation for the extruder? I know the nimble documentation says 1/16 microstepping, i dunno how interpolation would affect that.
You could also increase the motor current to your extruder to 800

Generally I advise using x16 microstepping with interpolation on the extruder if the resulting steps/mm is between 400 and 1000. If it's lower than 400 then use higher microstepping to bring it into that range. If it's above 1000 then my experience runs out.

Edited 1 time(s). Last edit at 05/31/2019 03:59PM by dc42.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Kossel Delta xxl build project HELP
May 31, 2019 07:53PM
The Nimble documentation says : For 32 but boards start at around 2700 steps/mm at 1/16 microstepping.
This is what I have : M92 X200.00 Y200.00 Z200.00 E2700.00 ; Set steps per mm
Re: Kossel Delta xxl build project HELP
June 03, 2019 06:42PM
Hi David. I know you remember I was having problems with the temperature reading on the Hotend. I figured it out. I replaced this plug and now I have the bed temp 23 C and the Hotend 23.7 C. I installed everything back and I don't know why the Smart effector lights are not working anymore. There is any way to make the work again ?
Thank you.
Attachments:
open | download - IMG_20190603_174021.jpg (438 KB)
Re: Kossel Delta xxl build project HELP
June 04, 2019 02:01AM
The Smart Effector illumination LEDs turn on when the hot end fan turns on. Is the hot end fan turning on? You would normally configure it to turn on when the hot end temperature exceeds 45C.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Kossel Delta xxl build project HELP
June 04, 2019 07:50AM
Yes , the hot end fan turns on when the temperature exceeds 45C but no lights
Re: Kossel Delta xxl build project HELP
June 04, 2019 01:00PM
In that case it sounds like either one of the LEDs or the series resistor has blown. Did you run the effector at 24V with the "on for 12V" jumper installed? If you did then the 604 ohm series resistor has probably blown. If not, then most likely one of the 3 LEDs has failed - which is unlikely but not impossible. The one with 12V or 24V across it is the one that has failed.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Kossel Delta xxl build project HELP
June 04, 2019 11:32PM
I finally figured out what was wrong with the extrusion. Now the extruder it is working good. I was able to calibrate the E steps/mm and trying to print. When I try to print the nozzle was to close to the bed. I heat up the bed to 60 C and the hotend to 190 C , move down the nozzle until I could just slide a piece of paper under the nozzle with some resistance. Then I sent G92 Z0 and G1 Z5 and G30 then I sent the print. Again the nozzle it is to close to the bed. Then I did again the Z probe trigger hight . Start printing again and the same problem. I did this a few times and I have the same results. I tried different models to print with the same results. What I'm doing wrong ?

Edited 1 time(s). Last edit at 06/04/2019 11:45PM by alex773.
Attachments:
open | download - 15597062576522122651539881191025.jpg (385.9 KB)
Re: Kossel Delta xxl build project HELP
June 05, 2019 03:19AM
Check the Z probe trigger height is set up correctly in the G31 command in config.g. For the Smart Effector, it should be about -0.1mm. Heat the bed to printing temperature, also heat the hot end to printing temperature (or to a little lower if the bed surface doesn't like being probed with a hot nozzle). Home the printer, run one cycle of auto calibration (G32), then print. For best results, don't home the printer again between auto calibration and printing. So either don't include G28 in your slicer start GCode, or if you do then put a G32 command after it.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Kossel Delta xxl build project HELP
June 05, 2019 11:29AM
Thank you David for your quick response. I did what you said. I home the printer and I sent G32. The nozzle goes down halfway and starts execute G32 ( Z probe was not triggered during the probing move. Compensation or calibration cancelled due to probing errors ) . I tried a few times and then finally go through. When is printing the green light for probing it stays solid green. this is what I have in Config.g :
; Z-Probe
M558 P5 R0.4 H5 F1200 T6000 ; Set Z probe type to effector and the dive height + speeds
G31 P100 X0 Y0 Z-0.1 ; Set Z probe trigger value, offset and trigger height
M557 R149 S20 ; Define mesh grid

Edited 1 time(s). Last edit at 06/05/2019 11:31AM by alex773.
Sorry, only registered users may post in this forum.

Click here to login