X and Y will home, but will not read G1 from SD card
October 09, 2023 03:35PM

I am building a simple bot using Marlin Firmware and TMC2209 stepper motors. This machine runs the X, Y and Z axis and it's purpose is simply to dispense glue. My issues is that for some reason when I insert an SD card and select a simple g-code program it will run the homing for X, Y and Z, but then commences to only run the Z axis, X and Y will not move. This is frustrating as when I connect to pronterface everything works fine all axis respond. I have tried a myriad of different g codes and sequences and every time it's the same, everything will home, but only the z will run. I have attached my modified Marlin config files along with a one code I've tried to run. I have read through a many different forums, but haven't found any solutions. I have tried using the 998 and 999 dummy thermistors, and have played with the feed rates.

Thank you in advance!
open | download - 2250-03_0019-00.g (144 bytes)
open | download - Configuration_adv.h (181.9 KB)
open | download - Configuration.h (129.7 KB)
Re: X and Y will home, but will not read G1 from SD card
October 09, 2023 09:59PM
Gcode is by default case sensitive

It Must be upper case, G1 not g1, M106 not m106

all the lowercase lines are ignored, unless you enable GCODE_CASE_INSENSITIVE

Pronterface knows this and converts to uppercase automatically

Edited 6 time(s). Last edit at 10/10/2023 07:01AM by Dust.
Sorry, only registered users may post in this forum.

Click here to login