Welcome! Log In Create A New Profile


xubuntu instalation

Posted by dissidence 
xubuntu instalation
May 01, 2011 10:10PM
i an not a total newb to linux i can normaly get things i want installed but i seem to be running into issues trying to get repsnapper to install on my xubuntu systems that i want to be my main printing setup. from what i can tell i have everything installed but i get this message in the CLI when i try to start repsnapper

repsnapper: error while loading shared libraries: libreprap.so: cannot open shared object file: No such file or directory
but i have followed the instalation instrutions for librerap, but i am not sure if i need to do the last part of the install

By default, the files are installed under /usr/local/, but some distros don't
include it into the search path for dynamic libs (running a binary that links
against libreprap might reports something like "Can't find libreprap.so" or so).
There are two ways to fix that:
* Change the install prefix to /usr/ instead of /usr/local, which is not recommended
* Add /usr/local/bin to ld.conf by creating a file /etc/ld.so.conf.d/local.conf which includes only the line "/usr/local/lib"
** run "sudo ldconfig" afterwards
i dont get the same error they discribe, but i am sure i have it installed

Re: xubuntu instalation
May 11, 2011 07:26AM
On ubuntu 11.04 I had to change the lib path, by first calling "ccmake ." and change the directory to /usr/. Then it worked.

Building and installing:
* "cd libreprap"
* either:
** "cmake ."
** or "ccmake ." or "qcmake ." for changing the install prefix or adding the debug flag
* make && sudo make install

Remember to "cd" between installing libreprap and repsnapper, if not the directories will not be in the correct spot.
Sorry, only registered users may post in this forum.

Click here to login