Welcome! Log In Create A New Profile


Isaac Mendel build

Posted by jkelso 
Re: Isaac Mendel build
October 01, 2010 11:35PM
The whole thing sounds like a mess to me BUT I can tell you if they put you to work they HAVE to pay you... period.. 22.20 or close minus tax......
Re: Isaac Mendel build
October 02, 2010 03:14PM
Still waiting on the digikey chip but the package postmarked Sep 30th from techzone came in the mail today. The soldering looks accepable and there are no visibly fried chips so I'm hopeful it works if the thermocouple chip or thermistor doesn't solve my problem. I intend on sending back to them a board shortly. I have to say I do appreciate that they came through but I'm still reluctant to give them much credit because they claim that this is the 2nd board they've sent. If that is so then the first board should have arrived in the mail by now. I never received a 1st board and it's disappointing that they would come through so half assed with the replacement. Maybe somebody is having memory problems or some other unforeseen circumstance, but at this point I feel 50 percent satisfied (tentatively).
Re: Isaac Mendel build
October 02, 2010 03:58PM
Just now I decided to try and hook up one of my new 100K NTC thermistors I got. I don't know exactly which code to use in the thermistor table for this thermistor but I was able to obtain an accurate reading of room temperature through the arduino by modifying the multiplication value for celsius to 7 instead of 100 as shown on the wiki. Now that I've figured out how to get the accurate reading this way I just need to figure out how to code the firmware for my reprap electronics and reupload it and attach the thermistor.
Re: Isaac Mendel build
October 02, 2010 04:55PM
That test code is designed for the AD595; it won't work correctly for thermistors. After your adjustment, the further you get from room temperature, the further the reading will be off. Also, did you add a 4.7k pull-up resistor? The extruder board includes it (see [reprap.org] "Temperature" section) but the Mega doesn't. The pull-up is necessary for correct operation.
Re: Isaac Mendel build
October 03, 2010 12:03AM
No I haven't added a 4.7k pull up resistor I've been trying to reconfigure the firmware all night but still no reading using this thermistor. Hopefully I'll get better results once I've installed the resistor. I've still not switched out the extruder board yet but I plan on doing that soon...
I'm looking at this setting in the reprap console preferences for extruder ohms ...I changed to to 100000 not sure if that's right.

Re: Isaac Mendel build
October 03, 2010 09:55AM
I think Extruder0_Rz is one of the large number of do-nothing parameters that's a holdover from the PIC electronics angry smiley
Re: Isaac Mendel build
October 03, 2010 12:10PM
magnets...how do they work?
Re: Isaac Mendel build
October 03, 2010 12:53PM
Didn't the Insane Clown Posse answer that?
Re: Isaac Mendel build
October 03, 2010 10:15PM
jkelso Wrote:
> magnets...how do they work?

As a reprap part? They are sometimes used to hold a steel build platform in place, to avoid the need for clips or other fasteners.
Re: Isaac Mendel build
October 05, 2010 02:25PM
Never heard of him. I'm talking of these rotary encoding magnets. I got the new AD595 chip from Digikey today...

Re: Isaac Mendel build
October 05, 2010 05:38PM
If I am following your build properly, then you are using a stepper motor to drive your extruder, and so you don't need to worry about a rotary encoder. Its used to track the motion of a motor so that you know how far it has moved, with a stepper you just need to keep track of the steps you send it. It could be useful if you wanted to check whether the extruder stepper was missing steps.

If you want to attach it anyway, then it goes to the 10 pin header on the bottom of the board, which appears to be marked 'quadrature' on the standard version, I don't have good pictures of the techzone version. The pinout is on the extruder board diagram. Since this is not a standard option, it may not be easy to get the firmware to do anything useful with this combination.
Re: Isaac Mendel build
October 09, 2010 03:58PM
OK thanks. Today I've finally got some time to work on this thing uninterrupted. I replaced the extruder board and noticed that there are also 2 resistors which are not supposed to be touching together near the 12v terminals on the old board I'm sending back. I plugged in the new extruder and it seemed to light up fine and I uploaded the firmware to it no problem. I've also got the new AD595 chip installed and I'm hooking up the wires...

Edited 1 time(s). Last edit at 10/09/2010 03:59PM by jkelso.
Re: Isaac Mendel build
October 09, 2010 05:04PM
After hooking up all the wires on the thermocouple board correctly as shown on the board to the 3 pins on the extruder board A6, +5V,. and GND I got a red LED light on the thermocouple board which is supposed to indicate the signal wire is not hooked up correctly. I started up the reprap console but all I got was the same old 0. I removed the signal wire and touched it to other pins on the board, some lit up the red LED when touched, others did not. After getting no results, I decided to try and switch the polarity of the 5V and GND, which had no positive effect. Now, I cannot get that red LED to come back on, which indicates that another chip is blown. Before I can proceed with buying expensive thermocouple parts again, I want to at least get some kind of temp reading in the reprap software using just a thermistor and the 4.7K resistor which I'm going up to purchase now.
Re: Isaac Mendel build
October 09, 2010 05:13PM
Theres already a pullup resistor on the extruder control board, you only needed to add one when you were trying to read from it on your arduino mega board.

Go back to the stock extruder firmware, configure it to use a thermistor, wire the thermistor to the extruder board thermistor header, and see if that works. Don't worry about type of thermistor for now, though post any part numbers you have for it, just connect it up and see if we can finally get a temperature reading out of that damned extruder board.


The thermistor header is connected to pin A3, when putting the stock firmware onto the board ensure that TEMP_PIN is set to 3

Edited 1 time(s). Last edit at 10/09/2010 05:17PM by Andrew Smith.
Re: Isaac Mendel build
October 09, 2010 05:22PM
Thank you, now I won't have to go looking for that resistor at radio shack. I'm pretty sure the AD595 chip is blown again so I may be ordering another one now. I tried reversing the 2 wire ribbon cable that connects from the motherboard to the extruder
board and finally got my first positive reading in the reprap console. There was no signal coming in for it to measure, but I'm now hopeful that the reversing of this cable may be the key to solving this problem. The temp was showing at 490 C so I tried to ramp it to 800 C to see if I could get it to heat up but so far nothing. I'm going to try and connect the thermistor and redo the firmware now.
Re: Isaac Mendel build
October 09, 2010 05:43PM
I changed the firmware back to use thermistor on both the motherboard and extruder board .pde files. Now, I am back to a reading of 0 in the reprap software. Still no heat. I'm wondering, which cable on here is activating the C+/- terminal voltage? There's the 2 wire ribbon cable for temp, is this the same cable?
Re: Isaac Mendel build
October 09, 2010 06:10PM
I switched the wires for the nichrome wire to the A +/- terminals and powered up the electronics and the extruder nozzle got hot right away. So I know that it potentially could work if I can get it to. I changed the wires back to the C terminals and now I've got a reading in the reprap console of about 875 C. When I touch the K thermocouple temp sensing wires to the temp pins I get the reading of 875C and when I take them off it goes to 2 C. This could be progress.
Re: Isaac Mendel build
October 09, 2010 06:23PM
I restarted the console and, magically, I'm now getting a close to accurate reading putting a thermistor on the temp pins 39C.
Re: Isaac Mendel build
October 09, 2010 08:14PM
With the thermistor now giving me a temp reading, I have now been able to switch on the heat and feel the nozzle getting warm. At times during this process of building the reprap I've felt that maybe this could turn out to be one more of life's cruel jokes and that this will never work. I've yet to print anything, but I've made some major progress on this now. Today I kept getting visited by the usb cable gremlins, who often disable the link to the reprap. After a few hours of messing around with it I finally switched cables and redesignated the com port to get it all working again. I have 2 cables, the tech zone adapter with cable and a direct usb to ttl cable. If you are building a reprap I would recommend getting both types of cable, don't rely on everything working with only one cable because sometimes one works and sometimes the other one works. Sometimes I jiggle the handle and then it pops back on. But now it's working, thanks to everybody who gave advice and support and even for the vague answers I've been bitching about. Peace!
Re: Isaac Mendel build
October 10, 2010 01:09AM
Congratulations! Getting closer to plastic....
Re: Isaac Mendel build
October 10, 2010 05:49PM
Preparing now for my first extrusion. The nozzle is ramped up to about 180 C and I've got my 5lb roll of plastic ready to go on the chair for now. Once things get rolling I'm going to build the holder that goes on top of the machine for the plastic . I've got the blue tape on there and I've set home in the upper left corner of the build platform if the square shaped dump area is at the bottom.
Re: Isaac Mendel build
October 10, 2010 06:54PM
After watching the gears turn for some time, I unplugged everything and took it to the work bench and removed all the twist nuts with springs and finally got enough room so that I could wedge the filament down in there. Once in, I put it all back together and tightened it down. I got the heat ramped up past 250C and tried extruding again, but the motor only turned and didn't grab on to the filament. So for some time I tried tightening to the point where the motor would stall and not make noise but not turn, then loosening again. Finally, I could feel the filament move when I pressed extrude. I pressed it again more than twenty times until finally I could see the plastic coming out the hole. So far so good!

Re: Isaac Mendel build
October 10, 2010 07:03PM
As I continued to try extruding some more plastic, it seemed like suddenly there was no more coming out. So I kept pressing the extrude button and it seemed to be going in at the top, then I realized that there was black plastic coming out of the side of the tape and that the filament had also pushed the extruder nozzle out of the base. Looks like I have some more work to do to get this extruder ready to print.
Re: Isaac Mendel build
October 10, 2010 10:40PM
I took apart the nozzle from underneath the extruder body and realized that it wasn't black plastic leaking from the tape, the nozzle was melting one of the plastic brackets that it had pushed against when it slipped out of the hole. I realize now that I never did put cement in there to hold it in place. I was thinking that the bolt going through the side would be enough to hold it, but apparently not. The bracket is still structurally fine and the melted plastic will not affect anything mechanically. I can see that the filament has a groove cut into it from going through the hobbed M8 bolt. I think I'll heat up the nozzle again and pull out the plastic. I also have to remove the entire extruder body which should take a good amount of labor, I'll probably start on it tomorrow.

Edited 4 time(s). Last edit at 10/10/2010 10:46PM by jkelso.
Re: Isaac Mendel build
October 11, 2010 02:10AM
It is getting closer but still fighting you all the way. I do hope I can learn from all of your problems and solutions posted here. Thanks.
Re: Isaac Mendel build
October 11, 2010 12:39PM
I am looking at the plastic part of the nozzle and there is a small white plastic tube inside of a larger beige plastic tube. When I installed it the smaller white tube was pushed down inside of the beige tube and there was a metal clip that held fit down inside of there. Now I see that the clip came out and the smaller white plastic tube is coming out of there. Maybe when it heats up I can move it. Looks like I might be needing to order another nozzle maybe.
Re: Isaac Mendel build
October 11, 2010 01:34PM
Common failure during tuning sad smiley ; I keep a supply of spare extruder parts on hand for whenever I get the urge to retune (change temp, extrusion rate, etc.)
Re: Isaac Mendel build
October 11, 2010 02:10PM
I pulled out the inner tube with some pliers and there was a length of filament which was attached to a melted puddle of plastic at the bottom of the inside of the outer beige tube. The inner tube would only go in about halfway. So I put the outer tube in the vise and drilled out the black plastic until I could see that I was drilling into the beige plastic. At the bottom I could see the hole again. I replaced the inner tube and the clip fit right in there. Looks like it should work again once I put it all together.

Edited 1 time(s). Last edit at 10/11/2010 02:11PM by jkelso.
Re: Isaac Mendel build
October 11, 2010 03:21PM
There's magic all up in this

Re: Isaac Mendel build
October 12, 2010 02:20PM
I took some time out this morning to ship back the old circuit board to techzone. I'd say that as of now I have 100 percent satisfaction. Since I don't have a job and I'm on a break from school until the 18th I have been taking time to relish the build and relax. After I finally roll out of bed and watch TV I usually take a nap again then finally try to start building this again. Today I've resoldered the thermistor to the wires because they needed to be stripped down further, all the plastic coating was melting. I rewrapped the wires with kapton tape and I'm now getting ready to apply the "fire cement" and let this dry before giving it all another try.
Sorry, only registered users may post in this forum.

Click here to login