SD Card not working + display not working
April 01, 2017 05:40AM
Hi guys,

Please share your oppinions on this because I'm getting overly frustrated:

1. I finished my Reprap running Marlin a couple of months ago and it's all working dandy in Pronterface. I didn't even check my SD card reader as I was printing directly from USB but lately I kinda need to let it print and take my laptop with me, not leave it there for hours and hours. Now I tried the SD card (16gb in a SD adapter), format it in FAT and after first try that didn't work (card inserted and detected but "no SD card" inside menu, I renamed the file using 8.3 format as I read Arduino needed and surprise! It worked and i could print. So the print started, everything fine, then suddenly, mid-print, something like a one second power drop happens, print failed and from the. i haven't been able to use my SD. Tried different capacities of cards (even a 64 mb one), nothing!! It detects the card inserted but I get "no SC card" in the menu.

So as i thought it may be a wrongly soldered pin either on RAMPS or arduino (keeping in mind the power drop) I ordered a new arduino+ramps+lcd as I wanted to start another printer also and I thought I could see if this new one would read SD Cards. If it did it was clear that my first SD Card reader is damaged.

2. I unwrapp the package (China) put everything together, I upload my final version of Marlin that is working great on my first printer and now another older nightmare hits me: the Rerap discount LCD is not working and it has the same simptoms my first one had when I was assembling: lights on but only row one and 3 are lighting with white squares. I solved my first one because it was a bent pin in the connection of the bridge with RAMPS. On the new one, there was nothing like that. So I tested my second display screen with my first, running setup on the printer and the screen works. So now I'm stuck!

Please help me with indications on testing RAMPS pins with a multimeter. I'm not an electronics degree so please tell me what to test, how to test and what should I be looking for. I have read a lot about faulty RAMPS.

Also, any ideea on how to make my SD card working would be great.

Re: SD Card not working + display not working
April 01, 2017 07:49AM
You need older slower smaller SD cards

I find anything over 8Gb seems unstable, and even then some brands just dont work.

most of the newer larger capacity cards no longer correctly support SPI mode...

re the display, Check the cables are around the same way as your first ones. Some suppliers started supplying lcd's with cables that are backwards (and keyed so you can't turn them around)
Re: SD Card not working + display not working
April 01, 2017 12:20PM
Thanks man,

You solved half of my problem. I didn't check the seems one of the two connecting the lcd to the ramps was "scratched". Either that or they were inversed (one pair were connected with the writing up and the other one down - though I don't see the issue there). Thing is I changed the cables, now the SD works fine.

I still have the issue with the LCD on the second one...I've got a feeling it's the RAMPS board.
Re: SD Card not working + display not working
July 11, 2017 12:59PM
I think I'm having a similar problem with my LCD display and SD card. Did you ever figure out what was going on with your LCD display? Also what did you mean by the connectors between the LCD and the ramps were "scratched" in your reply?
Re: SD Card not working + display not working
July 11, 2017 07:34PM
A follow up please. I'm having similar problems, but the smart controller seems to be working except for the SD card reader. The board is showing "card inserted" but the next screen says "no card". It seems like the controller is working otherwise. I unplugged the connections and replugged them, but still the same thing "card inserted" and then on the next screen, "no card". Confused. Thanks.
Sorry, only registered users may post in this forum.

Click here to login