Welcome! Log In Create A New Profile


Z-Axis jut falling down

Posted by Humbucker007 
Z-Axis jut falling down
April 20, 2019 05:12PM
I'm new to the diy-3D printer world and currently building a printer out of an old "pen an paper plotter".
I've got everything set up so far (Motors, Endstops, etc) and wanted to run some tests today. However, I ran into a major issue:
I can move an home my z axis just fine and even when lifted up it says in it's position. However, when I home any axis except the z axis, the software crashes in the following way:

The printer lifts up the z axis, does some weird noises, but does not really move the other axis and then just powered of the z stepper. This makes the y axis fall down in it's min position and the software crash.
The same happens, when I start a print.
Due to the software crashing it's unusable.
I already tried going into config.adv and disabling the standby/turn of of the y stepper, but it's still happening.

Here is a little video of me "homing" the printer:

Hopefully someone can help me.

Edit1: Please excuse me, I have forgotten to inforne you about my controller: It's an Arduino mega/Ramos 1.4 set up running Marlin with mechanical min Endstops switches.

Edited 1 time(s). Last edit at 04/20/2019 05:20PM by Humbucker007.
Re: Z-Axis jut falling down
April 22, 2019 08:57AM
Did you wire the endstep shorting out 5V to ground? That would cause a reset on the arduino (and may cause damage). Check the position of the end stop position on the connector. Check the board pinouts and orientation.

Edited 2 time(s). Last edit at 04/22/2019 09:01AM by imqqmi.

Kind regards

NFAN CoreXY printer:
Re: Z-Axis jut falling down
May 16, 2019 02:58AM
Have you tried just running the Z axis steppers?
I'm used to seeing the Z axis move up at the start of the homing sequence before going down, leading me to think you are running the wrong direction on your stepper(s) or simply stalling in the up direction. If your power supply isn't man enough for the steppers and they stall either because they can't lift the carriage or the carriage is blocked by the bed, the voltage could be falling to an unacceptable level for the processor and it brown outs, shutting the steppers off and then the PSU load drops restarting the processor.

I'd be looking at running the axis manually to confirm it will step on both directions and the direction is not inverted.

Edited 2 time(s). Last edit at 05/16/2019 02:59AM by SoundsDigital.
Sorry, only registered users may post in this forum.

Click here to login