Welcome! Log In Create A New Profile


M851 not working

Posted by georpo 
M851 not working
September 19, 2021 08:23AM
Hi all!
I have my TRONXY running fine with dual Z endstops and BLtouch since 2019.
Now suddenly (?) M851 does not work. EEPROM is of course enabled.
No matter the value of M851, the nozzle prints at Z0 height which is 1.6mm from the table.
Also if I type G1 Z0 the nozzle moves to Z0 height and does not add the M851 offset.
I tried:
M851 Z0
G1 Z0
M211 S0
M851 Z-1.6
M211 S1

I verify with M503 that the -1.6 value that I set is written in EEPROM.

I even reflashed the MKS board with the same firmware that used to work and then M502,M500 but again M851 is not taken into account.
Maybe this has to do with G29? I tried G29 before and after the above sequence.

Any ideas?
Re: M851 not working
September 21, 2021 03:06PM
Note that the Z offset value you set with M851 only applies the next time you home (G28). Also, it's only valid if you're homing with the BLTouch.
What does the LCD show for the Z position immediately after homing after you set the Z offset to -1.6? It should show 11.6 if the Z offset is working correctly (10 minus the Z offset).
Sorry, only registered users may post in this forum.

Click here to login