Piano riscaldato sempre acceso
August 28, 2014 08:58AM
Ciao a tutti,
Come da titolo ho un problema col piano riscaldato, Ho una ramps 1.4 e l'ho collegato, tramite un relay all' uscita D8 della ramps. Il mio problema è che il piatto rimane sempre acceso e non c'è modo di spegnerlo se non staccarlo, il led sulla ramps è sempre acceso e controllando sull' uscita 8 dell' arduino sono sempre su 4.98 V (1) anche disabilitando il piano da repertier host, da quel che ho capito quindi l' arduino non pilota il piatto, e ho provato anche a staccare la ramps ed alimentarla da sola, ma niente, il led rimane sempre acceso.
Grazie in anticipo
Re: Piano riscaldato sempre acceso
August 28, 2014 10:37AM
hai controllato che il termistore del piatto funzioni? la temperatura che rileva è giusta?

perché il relè?


Alessandro

Prusa I3 Rework molto modificata - Taurino Classic - Ramps 1.4 - Driver DVR8825 - Titan Extruder e Hotend E3D V6 - Bltouch originale - Firmware MarlinKimbra - Cura - Repetier Host
Re: Piano riscaldato sempre acceso
August 28, 2014 11:34AM
bilancia.... non chiedere perchè del relè però......non sei di "primo pelo" dai... dopo tante discussioni in merito.......... grinning smiley


Davide
Immagina e Crea
Progetto Flusso canalizzatore 4 vie
My Thingiverse
Re: Piano riscaldato sempre acceso
August 28, 2014 12:57PM
Se rispondo alle domande non è certo perché voglio fare il buon samaritano! lo faccio per imparare. Ora cerco qualche discussione su questo tema, di cui non mi ricordo di aver letto.

Le altre due domande restano valide... credo.

Edit:
tling! aggiornamento completato!

Edited 1 time(s). Last edit at 08/28/2014 01:55PM by bilanciamist.


Alessandro

Prusa I3 Rework molto modificata - Taurino Classic - Ramps 1.4 - Driver DVR8825 - Titan Extruder e Hotend E3D V6 - Bltouch originale - Firmware MarlinKimbra - Cura - Repetier Host
Re: Piano riscaldato sempre acceso
August 29, 2014 01:07PM
Eccomi, La temperatura rilevata è giusta, tantochè se lo collego si scalda e mi segna anche piu di 90 gradi, ma non si stacca, il led della ramps è sempre acceso, anche se stacco la ramps dall' arduino, misurando invece ho scoperto che l' arduino da sempre 5V (1) sull' uscita numero 8, che dovrebbe essere quella del piatto. ora ho provato a collegare il piatto sul 9 e a cambiare il pin di heater 1 ma nn sembra che funzioni faccio qualche prove.
Ah grazie per le risposte
Re: Piano riscaldato sempre acceso
August 30, 2014 05:53AM
Nessuno ne sa nulla?confused smiley
e lo so, son solo io ad uscirmene con questi problemi strani e mai visti.
Ieri nel frattempo ho mappato il piatto sul pin della ventola, ma nulla da fare non vuole saperne di funzionare...
il led rimane sempre acceso, sospetto una rottura del mosfet..
Re: Piano riscaldato sempre acceso
August 30, 2014 08:07AM
Verifica se non hai il firmware pasticciato, magari ricaricandolo.
Se il mosfet della ramps fosse rotto, rimappando dovresti riuscire ad evitare il problema, visto non credo il relè ti assorba troppo.
Se invece anche rimappando e spegnendo il piatto ti restano 5V fissi sulla nuova uscita allora guarda bene il fw.
Re: Piano riscaldato sempre acceso
August 30, 2014 09:29AM
Se cambiando uscita il problema rimane non è un problema della Ramps, a meno che tu abbia i due mosfet bruciati, ma a quel punto anche un eventuale ventola ti dovrebbe rimanere accesa sempre.
E' molto più probabile un problema nel firmware e/o termistore.
Forse mi sono perso un passaggio, ma il piano non è alimentato a 12V ?
Re: Piano riscaldato sempre acceso
August 30, 2014 11:03AM
Immagino i 5V fossero per l'uscita dell'arduino che pilota il mosfet che pilota il relè.
Re: Piano riscaldato sempre acceso
August 31, 2014 12:52PM
Eccomi, ho rimappato sul D09 ma nulla, ora non lo pilota maiisad smiley
Non so piu che fare, intanto ho ricontrollatoil collegamento col relè ed è tutto apposto, ma nulla tutto ok.
Per rimappare sono andato in Pins.h ed ho cercato dove c'è if define motherboard 33 ed ho sostituito define heater0 -1 con 9 e define heater 1 con -1
giusto? perchè usa -1 e non 8??
Un ultima cosa, oggi ho notato che le stampe mi vengono specchiate rispetto all'asse Y, ma è tutto settato giusto, se premo su repertier Y- si muove verso di me, se premo Y+ verso avanti, cosa può essere? la home è sattata con la punta dell' estrusore in alto sul piatto, e quando do il comando di home va verso l'endstop ma poi ci batte contro e continua a sforzare per alcuni secondi, ma poi fa la procedura di home tornando un po indietro e riprovando ad avvicinarsi all' endstop.
graziee e scusatemi per le mie domande da inesperto
Re: Piano riscaldato sempre acceso
August 31, 2014 01:30PM
per le stampe specchiate c'è un post esplicativo sul blog di Ivan Bortolin, comunque la Y 0 è dietro alla stampante quando viene avanti verso di te il valore aumenta.
I valori per diefinire gli hotend significano:
-1 = disabilitato
gli altri valori dipendono dal tipo del termistore che sono elencati nei commenti subito sopra a dove vengono definiti. Questo vale nel configuration.h

adesso probabilmente sto sbagliando, forse anche prima smiling smiley , vado a memoria, ma il piatto non è indicato come hotbed?
Re: Piano riscaldato sempre acceso
August 31, 2014 03:16PM
leggi la guida di MagoKimbra sullo spazio 3d e le direzioni nella stampante [forums.reprap.org]

nelle faq trovi anche un'altra guida sui pin e la rimappatura.

Edited 1 time(s). Last edit at 08/31/2014 03:17PM by bilanciamist.


Alessandro

Prusa I3 Rework molto modificata - Taurino Classic - Ramps 1.4 - Driver DVR8825 - Titan Extruder e Hotend E3D V6 - Bltouch originale - Firmware MarlinKimbra - Cura - Repetier Host
Re: Piano riscaldato sempre acceso
August 31, 2014 03:56PM
Quote
Dado_97
Eccomi, ho rimappato sul D09 ma nulla, ora non lo pilota maiisad smiley
Non so piu che fare, intanto ho ricontrollatoil collegamento col relè ed è tutto apposto, ma nulla tutto ok.
Per rimappare sono andato in Pins.h ed ho cercato dove c'è if define motherboard 33 ed ho sostituito define heater0 -1 con 9 e define heater 1 con -1
giusto? perchè usa -1 e non 8??
Un ultima cosa, oggi ho notato che le stampe mi vengono specchiate rispetto all'asse Y, ma è tutto settato giusto, se premo su repertier Y- si muove verso di me, se premo Y+ verso avanti, cosa può essere? la home è sattata con la punta dell' estrusore in alto sul piatto, e quando do il comando di home va verso l'endstop ma poi ci batte contro e continua a sforzare per alcuni secondi, ma poi fa la procedura di home tornando un po indietro e riprovando ad avvicinarsi all' endstop.
graziee e scusatemi per le mie domande da inesperto

Attenzione stai facendo un pò di confusione... Quei valori sono per l'hotend non per il piano riscaldato... infatti sono più di uno proprio perché si possono avere più hotend. La sezione che devi toccare è questa:
#if MOTHERBOARD == 35
    #define HEATER_BED_PIN     -1    // NO BED
  #else
    #if MOTHERBOARD == 77
      #define HEATER_BED_PIN     9    // BED
    #else
      #define HEATER_BED_PIN     8    // BED
    #endif
  #endif


Rimetti tutto a posto e fai queste prove.
Controlla se sui morsetti D8 c'è sempre la 12v anche con il bed spento. Se si hai sicuramente il mosfet rotto. A questo punto se metti un relé come stai facendo prendi un'altra uscita tipo la 5 o la 6 per abilitare il relé, attenzione però che non sono uscite di potenza e sono a 5 volt quindi non puoi metterci un relè diretto ci devi per forza di cose metterci un circuito che faccia sia da isolatore che da alimentazione al relè. A meno che tu non abbia già una shield arduino con relè.


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Re: Piano riscaldato sempre acceso
September 04, 2014 03:04PM
Non vamoody smiley, ho cambiato il pin del bed con il 09 ma nulla, non vuole saperne di funzionare, a questo punto?, il mosfet 9 funziona, la ventola la pilota
Re: Piano riscaldato sempre acceso
September 04, 2014 03:38PM
Si ma hai cambiato quello della ventola con l'8? altrimenti hai due funzioni sullo stesso pin. Secondo stai provando direttamente o con il rele? Non è che hai attaccato male il relè??


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Re: Piano riscaldato sempre acceso
September 11, 2014 12:51PM
Ciao, Allora io sto provando il piatto con il relè, che è collegato bene perchè se io alimento con 12V la bobina il piano si scalda.
Ho anche tolto la ventola dal Pin 9 mettendo il -1
Re: Piano riscaldato sempre acceso
September 12, 2014 01:47PM
Nessuno sa nulla??
grazie a tutti per l'aiuto
Re: Piano riscaldato sempre acceso
September 12, 2014 03:24PM
Io mica ci ho capito nulla, prima era sempre acceso mo non si accende più?!?!?!
Facciamo cosi, allega il tuo firmware con attach file e poi ci fai un disegnino per capire come hai collegato questo relé!!!

Edited 1 time(s). Last edit at 09/12/2014 03:24PM by MagoKimbra.


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Re: Piano riscaldato sempre acceso
September 15, 2014 08:39AM
ahaha hai ragione MagoKimbra, allora, ora non posso inviarti foto perche sono dal telefono.
ricapitolo:
-- -- -- BED -- -- --
- Dopo aver messo in funzione la mia stampante mi son trovato con i primi problemi di stampa, ho cosi collegato il piatto riscaldato tramite un relè, in modo da non sovraccaricare la ramps, ho cosi preso un relè da auto (12V 30A) e ho collegato la bobina sui contatti della ramps dedicati all' alimentazione del bed, ho fornito la seconta alimentazione prevista dalla ramps per il bed collegandola a + e - 12 Vcc (gli stessi dei motori), ho collegato il bed, in serie al contatto del relè a + 12, in modo che, quando la ramps pilota la bobina il relè si eccita e, chiudendo il contatto accende il piatto.
- A questo punto il bed non veniva pilotato adeguatamente durante la stampa, infatti talvolta si scaldava, altre si raffreddava, ma cio senza un ordine preciso, con controllo temperatura on oppure off.
- poi, causa una dimenicanza di stringere la vite del morsetto della ramps, un filo ha toccato sul telaio della stampante e il mosfet si è bruciato, infatti solo a questo punto ho scoperto che l' almentatore atx, fissato alla stampante tramite una staffa in alluminio sui fori che lo fissano nei pc, ha una certa dispersione di + 11.82 V rispetto alla massa, in ogni caso tutta l'elettronica è completamente isolata dal telaio, in quanto montata su uno spesso strato di plastica pet.
- Arriviamo cosi a mappare il bed sul pin 09, spostando i 2 fili e modificando il firmware come da te spiegato. A questo punto il bed non si accende e non viene pilotato, ho verificato sul pin 9 dell' arduino, che rimane sempre a 0V.
sono arrivato qui, appena riesco ti posto schema e firmware.
Ah, dimenticavo, nella modifica ho provveduto a modificare i parametri stando attento a mappare l' heater 0 sul 10, il bed sul 9 e la ventola è stata disabilitata inserendo -1
Ciao, e grazie ancora per l' aiuto

Edited 1 time(s). Last edit at 09/15/2014 08:41AM by Dado_97.
Re: Piano riscaldato sempre acceso
September 27, 2014 04:00AM
Ieri ho riprovato ma nulla...
non so piu che fare, nel frattempo un driver è andato .. sigh
Re: Piano riscaldato sempre acceso
October 09, 2014 09:16AM
Stesso identico problema prima sempre acceso, adesso sempre spento
Re: Piano riscaldato sempre acceso
November 11, 2014 05:00PM
Ciao,
ho avuto un inconveniente simile con il primo relè a stato solido che ho usato,
in questi relè c'è differenza tra un carico in AC o in DC infatti se si applica un carico in DC ad un relè SSR per AC si ottiene che il relè non commuta più,
meglio commuta solo al primo comando...problema che non sussiste con i relè meccanici.
Re: Piano riscaldato sempre acceso
April 26, 2015 02:35PM
Ciao,
ho un problema simile sulla mia Hephestos con Arduino Mega,ramp 1.4, Marlin e piatto riscaldato dual power: il piatto purtroppo non si accende.
I collegamenti sono i seguenti:
- il piatto è alimentato direttamente da una PSU a 24V-10A ma ho inserito un relè, preso dal sistema aria condizionata della macchina della mia ragazzawinking smiley collegato a D8 della ramps che dovrebbe garantire la corretta temperatura del piatto.
- un termistore direttamente collegato alla ramps per leggere la temperatura del piatto.

Se provo a dare i 12V al relè il piatto si riscalda ma il problema è che su D8 ho sempre 0V e quindi il piatto non scalda.
Ho pensato che dovessi alimentare gli 11A, ho provato con un caricabatterie da 12V-1A ma D8 è sempre a 0. Forse 1A è troppo poco.

E' necessario alimentare gli 11A? Come posso farlo dall'alimentatore 24V-10A senza che si bruci tutto?

Grazie dell'aiuto,
Re: Piano riscaldato sempre acceso
March 25, 2016 04:27PM
Salve chiedo un aiuto, anche io ho un problema con il relè della mia seconda stampante, premetto che sulla prima stampante il relè funziona alla perfezzione mentre nella seconda stampante ho un problema che non riesco a capire, in pratica collegato il relè alla ramps da repetier accendendo il piatto si vede il led che si accende mentre se spengo il led si spegne dunque vuol dire che il relè funzione ma il problema è che il piatto rimane sempre acceso appena accendo l'alimentatore già comincia a scaldare ancora prima che io lo accenda da repetier vi posto il collegamento sia del relè e del letto riscaldato se poi qualcuno mi puo essere di aiuto...ha dimenticavo di dire che il termistore funziona e rileva la temperatura.
Image error
File not found.
open image URL
Image error
File not found.
open image URL
Image error
File not found.
open image URL
Image error
File not found.
open image URL
(Grazie)
Re: Piano riscaldato sempre acceso
March 25, 2016 06:15PM
Se lo hai attaccato come hai disegnato non può che essere solo una cosa che il relé quando è acceso il led apre il contatto sempre chiuso.. Quindi quando si attiva il bed in effetti lo spegni e viceversa..
Basta che controlli con un tester se c'è continuità quando il led è spento e quando è acceso...


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Re: Piano riscaldato sempre acceso
March 25, 2016 06:38PM
allora dove sono collegati i fili che vengono dalla ramps al relè numero 3-4 se da repetier il piatto è spento il 3-4 del relè non cè nessuna alimentazione è a zero, mentre se accendo da repetier il piano riscaldato si accende il led rosso del relè e nel 3-4 dove collegato i fili della ramps passano i 12v, però il problema anche se io accendo e spengo da repetier sia che il led rosso del relè sia acceso o spento il piatto rimane sempre acceso non riesco a capire da dove possano arrivare i 12v senza che io li attivo da repetier ( a led spento dove sono connessi i fili che arrivano dalla ramps al canale 3-4 del relè non cè nessuna continuità non ci sono i 12v come fosse spento mentre il piatto continua andare lo stesso) Mentre nel relè al canale 1-2 che sia spento o acceso il relè passano sempre i 12v

Edited 2 time(s). Last edit at 03/25/2016 06:43PM by Max-29.
Re: Piano riscaldato sempre acceso
March 25, 2016 06:53PM
Allora è in corto il relé... Prova con il tester in continuità se c'è corto tra 1 e 2 anche se non è collegato a nulla...


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Re: Piano riscaldato sempre acceso
March 25, 2016 07:59PM
allora ho provato con il tester sul canale 1-2 risulta a 0v se collego la usb al pc rimane sempre a zero se accendo l'alimentazione il tester sul 1-2 mi da - 036v mentre il 3-4 essendo dalla ramps spento mi da zero ma il piatto è acceso e scalda lo stesso, se invece accendo da repetier il canale 3-4 dove è collegato la ramps passa 12v mentre nel canale 1-2 rimane sempre - 036v, ho notato il collegamento dell'altro relè collegato sull'altra stampante, allora è collegato come la foto del mio disegno però ad alimentazione collegata al canale 1-2 ci sono i 12v mentre nel canale 3-4 della ramps è a zero però quando accendo da repetier il piatto sul canale 3-4 della ramps arrivano i 12v mentre nel canale 3-4 che prima cerano i 12v va a zero o rimane 1,26v praticamente come che si spegnesse.
Re: Piano riscaldato sempre acceso
March 26, 2016 04:06AM
Max se tu con il tester in V guardi tra 1 e 2 è normale che non vedi nulla.
Tu vedi la differenza di potenziale tra un morsetto e l'altro, ma se passa tensione tra un morsetto e l'altro hai lo stesso valore quindi differenza di potenziale nessuna o quasi...
Guarda tra il morsetto 1 e gnd e vedrai che come accendi l'alimentatore hai i 12 V..

Oppure se ti metti in ohm con il tester e con tutto spento metti i puntali tra 1 e 2 vedrai che ti segna continuità cioè 0 ohm o poco di più...

Edited 1 time(s). Last edit at 03/26/2016 04:08AM by MagoKimbra.


COMPRA ITALIANO - sostieni le nostre aziende - sostieni la nostra gente - sostieni il tuo popolo - sosterrai te stesso.
Alberto C. felice possessore di una Kossel K2
My Blog - My Thingiverse
Re: Piano riscaldato sempre acceso
March 26, 2016 05:29AM
Da qualche parte ho letto che con gli SSR è meglio interrompere il negativo, prova a invertire
Sorry, only registered users may post in this forum.

Click here to login