Welcome! Log In Create A New Profile

Advanced

which Arduino IDE to be used with Marlin

Posted by marvin42blue 
which Arduino IDE to be used with Marlin
December 26, 2019 12:12PM
Hi there,

I recently had issues when compiling Marlin with different Arduino IDE versions. Since I was not able to find any information which version Arduino works with which Marlin, here is what I observed. I'm using a Delta printer (Kossel mini, with ATmega 2560 + Ramps 1.4)

Arduino (Win) 1.6.9
- compiled and worked well with all Marlin 1.1.0 versions
- compiled Marlin 1.1.9 - but my Printer behaves weird (motion speed is not correct)
- does not compile Marlin 2.0.1 - aborts with lots of errors

Arduino (Win) 1.8.10
- compiles and works well with Marlin 2.0.1
- does not compile 1.1.9 - gives error "Old configurations ?" - but I have no "#include" in my configuration*-files
Re: which Arduino IDE to be used with Marlin
December 27, 2019 03:44AM
Don't use anything older than arduino 1.8.9
And don't try to use old marlins older than 1.1.9

the error #error "Old configurations? Please delete all #include lines from Configuration.h and Configuration_adv.h."

Happens when something somewhere includes the file Conditionals.h which is an obsolete file. Designed to catch someone trying to use old configuration files on newer versions of Marlin
Re: which Arduino IDE to be used with Marlin
December 27, 2019 11:27AM
Recently I switched to Atom with PlatformIO. I'm not sure if this works for < Marlin 2.x but it works really well in my experience.


http://www.marinusdebeer.nl/
Re: which Arduino IDE to be used with Marlin
December 27, 2019 07:22PM
Quote
Dust
Don't use anything older than arduino 1.8.9
And don't try to use old marlins older than 1.1.9

Would you please mind to explain this ?- Marlin requires C++11, so anything > 1.6.8 will/should compile proper code.

My 3D-prints were not different while I used older Marlin FW - actually some things are now even worse: the encoder on my SmartController was working very nice before, with 2.0.1 it's almost unusable.
Re: which Arduino IDE to be used with Marlin
December 28, 2019 09:22AM
Quote
marvin42blue
Quote
Dust
Don't use anything older than arduino 1.8.9
And don't try to use old marlins older than 1.1.9

Would you please mind to explain this ?- Marlin requires C++11, so anything > 1.6.8 will/should compile proper code.

My 3D-prints were not different while I used older Marlin FW - actually some things are now even worse: the encoder on my Smart Controller was working very nice before, with 2.0.1 it's almost unusable.

I have been using Marlin 1.1.5 when I upgraded to Marlin 1.1.9BF then Marlin 2 and though the benefits of the upgrades were not very notable. I did a few features that made it worthwhile.

Computer problems be back soon and finish!!!!!!

Sorry about that Upgraded from a 2TB windows 7 OS to a dual 1TB Drive windows 10 OS and having problems with the D: drive, keeps getting lost may need new Cables.
Kept the Windows 7 Hard Drive just in case.


Continuing
#define TEMP_SENSOR_CHAMBER
#define BABYSTEPPING
#define X_DUAL_STEPPER_DRIVERS
#define Y_DUAL_STEPPER_DRIVERS
#define PARK_HEAD_ON_PAUSE
Stepper Drivers easier to use
S-Curve Acceleration
Junction Deviation Factor
Just a few I wanted too experiment with.

Edited 3 time(s). Last edit at 12/28/2019 10:08AM by Roberts_Clif.


Electronics Technician / Computer Programmer
Sorry, only registered users may post in this forum.

Click here to login