Welcome! Log In Create A New Profile


Hangprinter version 3

Posted by tobben 
Re: Hangprinter version 3
October 21, 2018 04:08PM
Made a pull request to get this fix merged upstream in stock Marlin as well: link.

Thanks for reporting.

Re: Hangprinter version 3
October 21, 2018 05:32PM
Thanks, I’ll try that out!
Re: Hangprinter version 3
October 22, 2018 04:40AM
Great, I hope it works now smiling smiley

On your second question:
Is there a configuration change in the stepper_nano_zero FW (aka Smart Stepper FW) to tell it to use D0 and D1 pins for STEP/DIR?

I took a look in the Smart Stepper Firmware to find more details on how we might make it run on Mechaduinos. Looking at boards.h, try these settings:
linke to line on Gitlab

Comment out
#define NEMA17_SMART_STEPPER_3_21_2017
Link to line on Gitlab

Comment out
Link to line on Gitlab

And also, as you suspected. Dir/step pinout has changed. Actually, it looks like Trampas has just swapped them, see
#define PIN_STEP_INPUT  (0)
#define PIN_DIR_INPUT   (1)
Link to lines on Gitlab

Then, I noticed another difference. Mechaduino firmware sets step/dir, and enable pins in INPUT mode (source). Smart Stepper firmware sets them in INPUT_PULLUP mode (source). If your experiencing problems with the step/dir signal on your SmartStepperFirmware powered Mechaduino board, try changing the step/dir/enable pin modes.

I know it sounds quite optimistic to say this after all these details, but I think running SmartStepperFirmware on the Mechaduino hw should actually work smiling smiley

Re: Hangprinter version 3
October 23, 2018 03:12PM
Hello again guys. Finished building my hangprinter v3 without mechaduinos and i've spent the last week or so just fine tunning it. The major issue i'm struggling with is the calibration and precision of the extruder movements.

The best i've achieved is a 5% error on the X axis and 12.5% error on the Y axis. So i'm looking for tips into improving this, especially the y axis offset.

I've been testing it using a simple 40 mm square and making some minor and not so minor updates on BX, BY and CX, CY in the firmware. But it seems like i've hit a wall.

I've even manually remeasured at least 3 times all the required distances and started from scratch the fine tuning in firmware, but to no avail.

So guys any tips?
Re: Hangprinter version 3
October 23, 2018 04:30PM
Have you looked through Configuration.h and set all the relevant values?

Re: Hangprinter version 3
October 24, 2018 04:10AM
Yep. I did the measurements as recommended in the Chris Riley build videos (part 2 and 3): [www.youtube.com]

My anchors are nailed to a wooden floor and the AY,BX,BY,CX and CY were measured against the mover on the floor level, then i set up the build plate (small wooden board) and zero'ed the extruder to the board. From there i did the ABC-Z measurements from the top of the mover to the floor (,not the board). And from the top of the mover to the ceiling anchor.

Honestly the X axis error doesn't bother me, because i can compensate for that, but the fact that diference between the X and Y axis is so great leads to the print being a bit skewed on smaller prints. The strange thing is i've done the calibration about 3 times from scratch and the errors remain the same. Well they start worse off, about 15% on X and 20% error on Y. But with tweaking they all go to about 5% and 12,5% respectively.

Maybe the filament is catching a little on one of the anchors? Since i couldn't find cheap ball bearings i had to 3d print both the spool ball bearing and the anchor ball bearings. The spool bearing work great, kinda quiet actually. The anchor ones are a bit smaller but seem to work. Probably gonna go use some WD40 on them and see if it changes anything.

I've also used 0.5 mm 18.8 kg nylon monofilament, the strongest they had available in a local store, nothing like the 50kg fireline you guys use. But i can get it pretty tight , almost like a guitar string and the mover is only able to move about a 1mm in every direction if i push or pull it, before returning to the original position.
Re: Hangprinter version 3
October 24, 2018 04:55AM
Hm.. When you measure by hand, it's important that you measure from the start point to the end point of one single line.

For example, when you've measured Bx, By, and Bz, take a fourth measurement Lb from the point where the line exits the anchor roller to the point where it enters the mover.
If you get sqrt(Bx^2 + By^2 + Bz^2) = Lb, then you've probably done all four measurements right.

Given the size of your errors, we can be quite sure that either something is wrong with the measurements, or you put a lot of line (> ca 15m) on your spools, so that it builds up a lot more than the default config allows.

I didn't watch through Chris' videos, but can you confirm that Mounted line is measured and configured right?

We use FireLines (or any brand of as straight UHMWPE fibres as possble) for stiffness, not for breaking strength. Nylon lines are springy and will allow your mover to vibrate a lot.

To really make the buildup compensation work well, you need to configure the fine decimals of Spool buildup factor and Spool radii as well, but save that for later.

I made the auto calibration mostly because the manual calibration procedure is so hard to explain. A complementary source on how to hand-calibrate is here. At some point I will have to stop trying to explain this hand measuring procedure. It's so hard.

Re: Hangprinter version 3
October 24, 2018 11:46AM
Ok tks. I'll sanity check the line lengths and mounted lines. Maybe thats the issue.

Edited 1 time(s). Last edit at 10/24/2018 12:29PM by LordThingol.
Re: Hangprinter version 3
October 28, 2018 07:25AM
I generate my 3D models via Rhino/Grasshopper. This software is not available for Linux and it is very time consuming to switch between the Linux and Win installation. I am using the HAW usb stick right now. I have no interest in running Rhino/Grasshopper and/or the hangprinter on a virtual system.

Does anyone run the hangprinter on Win10? If I would use Prontrface on Win10, what do I have to change in the standard software to use it with the hangprinter?
Does anyone run the hangprinter with Cura or Simplify 3D and is willing to share the settings?

Edited 2 time(s). Last edit at 10/29/2018 03:26PM by Dahah.
Re: Hangprinter version 3
October 28, 2018 07:33AM
You don't need to change anything to host from Windows, you can run Hangprinter from any 3d printer host software on any operating system winking smiley

If you find a slicer config meant for a big delta printer with a big nozzle, then that config will work for Hangprinter as well.

Re: Hangprinter version 3
October 28, 2018 09:42AM
spinning smiley sticking its tongue out Merci!

I'll try to generate g-code directly from my grasshopper patches and feed it to the hangprinter.

By the way....Is there an UI for OpenSCAD like the grasshopper UI (https://www.grasshopper3d.com/)

Edited 7 time(s). Last edit at 10/28/2018 04:29PM by Dahah.
Re: Hangprinter version 3
October 28, 2018 10:26AM
@Tobben Just reading the blog. Everything looks so promising! smiling smiley

Edited 1 time(s). Last edit at 10/28/2018 11:30AM by Dahah.
Re: Hangprinter version 3
October 28, 2018 12:13PM
=) I currently have two ODrives up and running with G95, G96, and M114 all working properly. A couple more work days, and we'd be ready to have HP4 in the ceiling for the first time.

I will have less dev time going forwards though, see Bountysource update for more details.

Re: Hangprinter version 3
October 28, 2018 04:28PM
=) Next Level!
Re: Hangprinter version 3
November 20, 2018 09:37AM
Hello Guys.
I'm trying to make the Hangprinter V3 and I would like to know if it is possible to made that without Mechaduino and, which firmware I have to use with A4988 drivers.
I used spools directly to motors with planetary gear reduction, and I added reduction factor on MOTOR_GEAR_TEETH and SPOOL_GEAR_TEETH ( the factor is 1:5). After anchors measurements and G92 X0 Y0 Z0 on Repetier Host, motors ABC do not ensure the tension of the wires, and movements on X and Y aren't possible.

Any issue or suggestion?

Re: Hangprinter version 3
November 24, 2018 08:27AM
I just tried the auto-calibration script, but ran into a problem. The value the script outputs makes no sense. Every anchor value is zero. Total cost value is a 7 digit value with 6 decimals. Cost per sample is a 6 digit value with 6 decimals. So something must be wrong, I just don't know what.

The data points seem to be ok. Do I have to change some values in the marlin config prior calibration?
Re: Hangprinter version 3
November 25, 2018 05:10PM
Howdy all!

Finally got to come back to my hangprinter build after many months working away from home.

I got it hanging up, calibrated (first attempt anyhow), and moving in the X and Y directions properly.

However, when I move it in the Z-direction, the ABC spools do not move at all.
I updated to the most recent firmware, and attempted again with the same results.

Has anyone run into this before?
Re: Hangprinter version 3
November 26, 2018 03:18PM
Hello all,
Yes, you can choose any driver you want. Read backwards in this thread for more on a4988.

Sloppy wires is almost always a result of not good enough calibration. Getting good calibration values can be a challenge. See previous discussion in this thread.

If the cost is large and values make no sense, then your data that you fed into the data was not accurate enough. Search for HANGPRINTER in Configuration.h and set all the values there as accurately as you can...

Not seen this before. How far in the Z-direction did you move? What is your anchor calibration values?

Re: Hangprinter version 3
November 26, 2018 07:29PM

The Z moves attempted were probably between 30-50mm by executing G1 Z30 commands in pronterface.

My calibration values are listed below.
ANCHOR_C_X -1049
Re: Hangprinter version 3
November 27, 2018 11:44AM
Hm... Are you sure that the ABC motors stood completely still, and not just moving too slowly?

Hm... G1 Z30 should generate only one movement even if you send it several times, unless you sent G91 to set the machine in relative mode before you started sending G1.

If being a pure z-move is the problem, then G1 X1 Z50 should be unproblematic. Is it, or do you still see the same problem?

From where did you download your firmware?

Re: Hangprinter version 3
November 28, 2018 08:51PM

EDIT: Upon messing around a little more, it appears that the ABC spools will move with a higher speed Z-move, but do not appear to be moving nearly enough to keep up with D spool

I believe they are completely stationary, but it may be linked to the speed.

Aha, I did not realize that the G1 commands were absolute, not relative that was my misunderstanding.

Executing a G1 X1 Z50 yields the same result, with the D-spool moving, but not the ABC spools

I downloaded my firmware from Github, and got the latest version on 11/24/18.
I'm wondering if there's something preventing my ABC motors from executing commands at a low speed.

Edited 1 time(s). Last edit at 11/28/2018 09:00PM by Alandaeta.
Re: Hangprinter version 3
November 29, 2018 02:36PM
Ok, thanks for double checking. It seems like you have a calibration issue. Unless you've built a machine with double ABC lines, or have configured your motors for something other than 1/16 stepping?

To confirm you have a calibration issue, try setting A_Z, B_Z, and C_Z to ca -200, and see if that is enough to prevent over tight lines. (You should re-calibrate all anchor positions anyways, but just check first if it will be enough to solve your problem).

There should be nothing preventing ABC motors from executing commands at low speed.

Re: Hangprinter version 3
December 03, 2018 12:59AM
I've had a mechanical issue with two motors which were attached too tightly to the spool cores. The friction prevented them from spinning back in torque mode. Check this if you can't find any configurational issues.

I managed to get the calibration script working with the other option -S(something). Will try the default option again this week. Last week I finished my first "real" print. A 500 mm tall statue. It would have been perfect if the filament wouldn't have run out eye rolling smiley
Re: Hangprinter version 3
December 03, 2018 09:29AM
Hi Lucernario. Yes you can build a hangprinter v3 without mechaduinos. I finished building mine about a month ago and you can achieve really excellent results. In my case i can print a 1:1 scale benchy without messing it up and a 20 mm calibration cube with less than 1 mm error. Seeing that i plan to use to print big, thats more than enough.

In the particular case of the wires, use dyneema not nylon (makes a load of diference) and be prepared to waste a couple of days (coff weeks) fining tuning the calibration. Hint: Be very very very precise on the ABCD line measurements.

You can watch Chris's videos on the subject: [www.youtube.com], sure helped me alot.

Hello Alandaeta. By what you're describing you seem to be having trouble moving the D motor. When i built my hangprinter i found some issues with G6 D motor commands, as they didn't work. This happened on version 1.1.9 of Marlin. Try installing this version of marlin on the hangprinter github page: [github.com]

Edited 3 time(s). Last edit at 12/03/2018 09:37AM by LordThingol.
Re: Hangprinter version 3
December 10, 2018 01:44PM
Hi guys, thanks for your advice.
I will try to do a new calibration of anchors much better, and I will post here my experience.

see you soon
Re: Hangprinter version 3
December 24, 2018 01:27PM
Whew, finally getting a little time to work on this project again.

Coming back to it today, I have set the A_Z, B_Z, and C_Z values to -200 as suggested. No noticeable differences upon moving it around, the ABC lines get loose and tight as the mover moves up and down, with the ABC spools only moving a little when moving the D line at high speed.

My X and Y movements appear to be working just fine, which is encouraging.
My next course of action will be to check if my steppers are set to anything other than 1/16 stepping.
Re: Hangprinter version 3
January 10, 2019 03:40PM
Hi Alandaeta.

It most probably is a calibration issue. Try replacing the anchor positions with even more accuracy and if it the problem persists try an even older version of marlin (https://github.com/tobbelobb/hangprinter).

You can also test individual motor movements using the G6 A,B,C,D #number# command.

Sometimes there's some motor skipping steps on long moves (if you're not using mechaduinos), especially on the z axis, you might want to increase voltage to stepper drivers or just check that their voltage is correct.

In my case, these are most of the issues i've runned into.

Still trying to improve my printers resolution, but hey we're makers. We love banging our heads against walls.
Re: Hangprinter version 3
January 13, 2019 09:15AM
@tobben @Alandaeta

We are also working on Hangprinter without mechaduinos, & getting same error like @Alandaeta had !!
When I move it in the Z-direction(G1 Z50), the ABC spools do not move & another error was when i gave 10 mm (G06 A10) feed it almost move more than 10 cms, I know it requires some change in setting or code but I couldn't solve it !!

I have tried with both the firm wares.

Anyone here with same difficulties ????
Any solution for the same ??

Edited 1 time(s). Last edit at 01/13/2019 09:18AM by jaxshah.
Re: Hangprinter version 3
January 16, 2019 10:21AM
Hi all, happy new year!

I have been some time with my printer stopped, no time to work with it. I had a double problem with my extruder. Before to be mounted I tested it and works fine. But them fails, the heater didn't heats and the stepper didn't move. Some times ok and some times no, ummm. I took part in Bilbao maker Faire with this disadvantage because the printer at least moves and was beautiful to see.

Now I start again and check wiring. The heater had a connector broken internally. The stepper a bad solder. Fixed.

So I have made my first print and see how the X-Y axis works corrrectly. Z works but it's not fine. If I put Z50 it rises only 35. Also a similar problem with flow. My extruder drives more filament than expected.

The result is a piece with a decent first layer but them, with each layer the nozzle is touching more and more the piece and finally must stop it.

I use 1mm nozzle and 0.5mm layer. I check the firmware and I'm confused because to correct this usually must tune the steps per unit parameter, but here are a different procedure and I'm not sure how to proceed:

// then constant ABCD values are calculated on the fly and used only used to calculate accelerations
#define DEFAULT_ESTEPS 410.0 // 410.0 set quite at random
#define DEFAULT_AXIS_STEPS_PER_UNIT {92.599, 92.599, 92.599, 92.599, DEFAULT_ESTEPS}

During this time I also have installed Octoprint and can control remotely the printer.

I have pending the insertion of two fan layer to cold plastic, without them the plastic is very soft.

Re: Hangprinter version 3
January 18, 2019 12:46AM

You should be able to fix the extruder by calibrating the esteps. I do it by extruding 100 mm filament and measuring how much filament goes into the extruder. There are formulas to calculate the esteps based on the the difference of those two measurements. I can check them later today

About the Z difference. Have you measured the spool radius and put it into the config file? That could be one reason. And the other that comes to my mind is the line length, which needs to be also put into the config file. For example my ABC line lenghts are 7500mm,.but the D line only 4000mm.

I too had an issue with a bad thermistor connector. It lead marlin think the thermistor had a defect and therefore halted the system. I will change the connector to get rid of this.

Edited 1 time(s). Last edit at 01/18/2019 12:47AM by atmark.
Sorry, only registered users may post in this forum.

Click here to login