Willkommen! Anmelden Ein neues Profil erzeugen

Erweiterte Suche

Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)

geschrieben von .xack. 
Re: Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)
02. October 2015 18:12
Die Eingänge müssen sich nicht zwingend gleich verhalten.
Nach Defekt schaut das aber nicht aus.
Häng das Teil doch einfach mal über einen simplen Spannungsteiler dran.

1-mal bearbeitet. Zuletzt am 02.10.15 18:14.


Einen Sparkcube 1.1XL für größere Objekte, einen Trinus3D im Gehäuse und einen Tantillus R im Bau und einen Qidi Tech Q1 Pro im Zulauf.
Sparkcube: Komplett auf 24V - DDP 8mm + 1,5mm Carbonplatte - Octopus max EZ - EZ2209 - Nema 17/1,7A 0,9 Grad - BL Touch - Filamentsensor - Titan Booster Hotend - Sparklab Extruder - Klipper/Mainsail - HDMI 7 V1.2 Touchscreen - Simplify3D
Re: Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)
03. October 2015 15:10
So, soweit funktioniert es. Gleicher aufbau wie im ersten Post. LJC12A3H-Z/BX + Optokoller

Aktuell habe ich den Sensor sehr hoch um nicht an die Klammern der Spiegel fliese zu kommen. Normal soll er ja bis 5mm messen, momentan habe ich den Schaltpunkt in 9mm vom Bett.
Wenn er aber auf der schwelle steht wo er mal Low mal High ist, kommt es zu Fehlern. Wo der Druck sogar hängt und stottert. Wenn er über die schwelle ist läuft er normal weiter.

Warum weiß ich aktuell nicht.
Endstops sind während des drucks deaktiviert. Das gleiche kommt beim SD Druck. Sowie im Leerlauf wenn er auf der kippe steht.

20:51:49.273 : Error:Wrong checksum
20:51:49.279 : Resend:758
20:51:53.529 : Resend:762
20:52:15.667 : Error:expected line 779 got 0
20:52:15.670 : Resend:779

Edit: Der Pull up vom Z-Min ist defekt, normale Endstops ohne Hardware funktionieren nicht mehr an dem Eingang.
Aktuell habe ich da irgendwo den Wurm drin, Und Kopf dampft schon hot smiley
Re: Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)
03. October 2015 15:22
Moin moin aus HU.
Mann, dann mach Dir doch selbst einen Pullup. 10KOhm an Plus und das andere Bein an den Signalpin.


Liebe Grüße aus Kaltenkirchen.
Frithjof
Meine Seite
[www.facebook.com]
Re: Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)
03. October 2015 15:25
Z-Max tuts ja auchsmileys with beer

EDIT: Ach, der Fehler kommt an einem Eingang wo der Pull up funktioniert. Also bringt ein externer bei dem Fehler wohl keine Besserung. Dachte das wäre klar von meinen Post vorher das ich den aktuell am Z-Max habe.

3-mal bearbeitet. Zuletzt am 04.10.15 11:43.
Re: Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)
18. October 2015 13:32
Hallo zusammen,

gerade fummele ich auch an einer Lösung mit dem Sensor aus dem Startbeitrag.
Der Anbau am Protos V2 ist ja denkbar einfach:


Meine Schaltung für den Pegelwandler sieht so aus:

Der extra Transistor sorgt dafür, dass beim Durchschalten ein "1" am Arduino ankommt und damit exakt so als wäre der Mikroschalter, wie normal, angeschlossen.
In der Firmware (Repetier) wurde beim Umbau, bis jetzt, nicht verändert.
Aktuell schaltet der Sensor immer zuverlässig durch.

Allerdings komme ich nicht auf die Genauigkeit die hier wohl alle ohne Problem erreichen.
Fahre ich von Hand an eine Stelle und messe mehrfach dann sieht es mit dem Blatt-Papier-Test sehr gut aus.
Fahre ich dann den Tisch um 100mm nach hinten dann schaltet er ca. 0,1mm (1.Blatt mehr) durch und der Abstand ist dann halt 0,1mm höher vom Tisch.
Das ist an dieser Position auch wieder zuverlässig und wiederholbar!

Es ist dabei egal ob ich nur mit Aluplatte oder mit aufgelegtem Spiegel (4mm) messe. Auch ob die Heizung ein oder aus ist macht keinen Unterschied.
Messe ich nur mit Aluplatte schaltet der Sensor ca. 0,3mm früher was natürlich auch nicht optimal aber erklärbar ist.
Der Höhenunterschied vorne und 100mm weiter hinten (Y-Achse) ist aber auch hier vorhanden.

Hat jemand dafür eine Erklärung???

LG

Wolfgang
Re: Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)
22. October 2015 09:53
Hi,

soweit funktioniert das Auto bed leveling. Mit Optokoppler und Kapazitiven Sensor. Also wie im Post 1.
Wenn der Sensor triggert und nicht triggert ist es Okay.

Nur wenn er schnell zwischen triggert und nicht triggert wechselt bekomme ich Errors. Diese schwelle kommt beim Drucken halt irgendwann wenn der Sensor über Objekten ist.

15:37:24.774 : Error:Wrong checksum
15:37:25.003 : Resend:21447


Ich kann mir aktuell nicht vorstellen woran das liegt.
Ich muss nach dem Messen immer das Sensor Kabel abziehen weil der Druckt sonst beim dem Triggert punkten die Errors bekommt und hängt.
"Wenn ich per SD Drucke passiert das selbe"

Repetier Server 0.65.0 auf dem RPi2
Repetier Firmware Mega 0.92.5
Re: Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)
22. October 2015 10:01
Moin moin aus HU.
Den Z-Stop in der Überwachung beim Drucken deaktivieren. Ist irgendwo ein Eintrag in der Config.


Liebe Grüße aus Kaltenkirchen.
Frithjof
Meine Seite
[www.facebook.com]
Re: Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)
22. October 2015 10:06
Habe ich
#define ALWAYS_CHECK_ENDSTOPS 0

Wenn der Sensor Triggert ist es ja okay, aber ein schnelles schwanken zwischen an/aus verträgt er nicht.

1-mal bearbeitet. Zuletzt am 22.10.15 10:07.
Re: Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)
22. October 2015 11:52
Dann hast Du irgendwo ein anderes Problem.


Liebe Grüße aus Kaltenkirchen.
Frithjof
Meine Seite
[www.facebook.com]
Re: Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)
24. October 2015 15:26
Kann mir keiner sagen warum der Sensor an verschiedenen Stellen auf dem Drucktisch (Spiegel 4mm auf Aluplatte) bei verschiedenen Abständen schaltet und ich dadurch einen Unterschied von ca. 0,1mm bekomme?

LG

Wolfgang
Re: Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)
25. October 2015 09:32
Habe eben letzte Tests zum Thema kapazitiver Näherungssensor gemacht.
Um auszuschließen, dass die Ungenauigkeit an einem defekten Sensor liegt hab ich einen anderen Typ eingebaut der gegen Minus schaltet.
Der erste schaltete gegen +!
Stehe ich ca. 5cm von der Vorderkante des Druckbetts und fahre dann Y nach hinten bis 5cm vor das andere Ende der Platte um neu zu messen, dann liegt die Abweichung wenn ich an beiden Stellen messe bei ca. 0,2mm.
Vielleicht hat das Haarspray auf der Glasplatte einen so großen Einfluss? Keine Ahnung woran es liegt.
Aus meiner Sicht absolut unbrauchbar für eine brauchbare und universelle Messung!

LG

Wolfgang
Re: Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)
05. November 2015 13:51
Quote
Kannst du mal einige Messungen (G30) machen und die Ergebnisse hier posten?
Woran kann es liegen wenn der Befehl G30 keine Reaktion beim Drucker zur Folge hat?
Muss das bed leveling in der Firmware aktiviert sein damit sich was tut?

LG

Wolfgang
Re: Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)
05. November 2015 14:00
Ja, muss aktiviert und konfiguriert sein... Siehe Kommentare in der configuration.h


--
Microsoft MVP in den Kategorien DirectX/XNA * Visual C++ * Visual Studio and Development Technologies seit 2011

  • Mein Erster (RAMPS 1.4, Selbstbau WolfStrap-Derivat mit Linearführungen, Wade Extruder und E3D lite6 Hotend)
  • Cub44 (Selbstbau Dual Wire Gantry Derivat mit Zahnriemen und Linearschienen, RADDS 1.5 und DUE, Custom Hotend - E3D like, Compact Bowden Extruder)
  • HexMax (sechseckiger Delta (eigenes Design) mit Druckraum 300mm Durchmesser und >=400mm Höhe, RADDS 1.5, 24V, Custom Hotend, Compact Bowden Extruder)
  • P3Steel Toolson MK2 - Keine Zeit zum selbst planen ;-)

Andere Projekte: FSR Board (ABL-Sensor-Platine inkl. Firmware) * ThirtyTwo (32Bit RepRap-Firmware)
Re: Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)
23. November 2015 12:43
Hallo zusammen,

mein auto bed leveling "klemmt" noch etwas.
Sowohl bei G29 als auch bei G30 fährt die Z-Achse 5 Mal nacheinander nur jeweils ein paar mm nach oben und steht dann.
Eigentlich wäre das der Fall wenn der Schaltzustand des Referenzschalters falsch definert wäre was aber doch nicht sein kann wenn G28 läuft?
G28 funktioniert ganz normal.

hier mal meine Configuration.h mit dem Bereich für das Z-probe:
/* Z-Probing */

#define FEATURE_Z_PROBE true  // false
#define Z_PROBE_PIN 18         // Z_PROBE_PIN 63
#define Z_PROBE_PULLUP true    // true
#define Z_PROBE_ON_HIGH false    // true
#define Z_PROBE_X_OFFSET 0
#define Z_PROBE_Y_OFFSET 0
#define Z_PROBE_BED_DISTANCE 5.0 // Higher than max bed level distance error in mm

// Waits for a signal to start. Valid signals are probe hit and ok button.
// This is needful if you have the probe trigger by hand.
#define Z_PROBE_WAIT_BEFORE_TEST false    // true
/** Speed of z-axis in mm/s when probing */
#define Z_PROBE_SPEED 2
#define Z_PROBE_XY_SPEED 150
#define Z_PROBE_SWITCHING_DISTANCE 1.5 // Distance to safely switch off probe
#define Z_PROBE_REPETITIONS 5 // Repetitions for probing at one point.
/** The height is the difference between activated probe position and nozzle height. */
#define Z_PROBE_HEIGHT 39.91          //39.91
/** These scripts are run before resp. after the z-probe is done. Add here code to activate/deactivate probe if needed. */
#define Z_PROBE_START_SCRIPT "M340 P0 S1400"     // ""
#define Z_PROBE_FINISHED_SCRIPT "M340 P0 S1000"   // ""

/* Autoleveling allows it to z-probe 3 points to compute the inclination and compensates the error for the print.
   This feature requires a working z-probe and you should have z-endstop at the top not at the bottom.
   The same 3 points are used for the G29 command.
*/
#define FEATURE_AUTOLEVEL false
#define Z_PROBE_X1 50      // 100
#define Z_PROBE_Y1 20
#define Z_PROBE_X2 100     // 160
#define Z_PROBE_Y2 170
#define Z_PROBE_X3 20
#define Z_PROBE_Y3 170

EDIT: Firmware ist Repetier 0.91

1-mal bearbeitet. Zuletzt am 23.11.15 12:44.
Re: Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)
23. November 2015 14:25
Hi,
Da steht ja auch define feature autolevel FALSE.
Das macht der Konfigurator falsch.

By the way: ich habe es gestern auch mal wieder mit der 0.91 versucht, weil bei mir mit 0.92 das Babystepping nicht mehr geht (Totalabsturz des Boards).
Autolevel geht bei 0.92 aber nicht mit den gleichen Einstellungen bei 0.91. Da fährt er nach den 3 Probes voj Bett weg und druckt lustig in die Luft.

Gruß, Stefan
Re: Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)
23. November 2015 14:31
Ok, hatte ich übersehen!
Gerade läuft ein Druck, dannach werde ich es ausprobieren!

EDIT:
Quote
should have z-endstop at the top not at the bottom.
Das ist beim PROTOS V2 natürlich nicht so! Was soll ich da machen?

LG

Wolfgang

1-mal bearbeitet. Zuletzt am 23.11.15 14:34.
Re: Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)
23. November 2015 16:33
Einstellung geändert, hat aber nichts geändert!
Einen Z-Max hab ich ja nicht.
Mir ist auch nicht klar wofür der an der Stelle gebraucht werden könnte wenn ich die Druckfläche abtasten will!
Das Problem bleibt also weiterhin, dass die drei Positionen angefahren werden da aber die Z-Achse irgendwie nach oben tasten will und nicht nach unten Richtung Tisch fährt.

LG

Wolfgang
Re: Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)
23. November 2015 17:18
Das ist ja irgendwie alles recht verwirrend!
If you send G28 you need 3 endstops. Z should home to z max where the z endstop should be. 

Put the zprobe on any free pin you have but do NOT set it in endstops. It is not a endstop it is a zprobe.

Then set it in zprobe section with pullup enabled so it is drawn to high internally until you connect the pin with gnd. Then G31 should also be consistent. I guess you missed the pullup part making it a random result.

Nach diesem Beitrag vom Repetier-Forum verstehe ich es so:
1. nach unten, Richtung Drucktisch, ist Z-Max
Da die Druckfläche ja aber die Bezugsebene ist und man von der Druckfläche weg druckt finde ich das unlogisch!

2. will man die bed auto leveling Funktion aktivieren braucht man für Z auf jeden Fall sowohl einen Schalter für z-endstop als auch einen Schalter als Sensor mit dem
der Drucktisch angefahren werden soll.
Irgendwie ist mir nicht klar wozu! Einer der beiden Schalter wird im Normalfall nie erreicht weil der andere vorher schon schaltet, also was soll das?

Kann mir da jemand etwas Erleuchtung bringen???confused smiley

LG

Wolfgang
Re: Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)
23. November 2015 17:33
Hi Wolfgang,
- hast du Autolevel auch im EEprom eingeschaltet?
- Der normale Z-Endstop muss ausgeschaltet sein (ist bei mir zumindest so; ich lege den Sensor aber auch auf diesen PIN)
- beim PRotos brauchst du den G29 überhaupt nicht (hast du oben geschrieben).

hast du das schon gelesen: [www.repetier.com]
Also die Anleitung hast du hoffentlich schon mal gelesen - aber das was da drüber steht auch?angry smiley


OK, Ergänzung nach deinem letzten Post:
Probiers mit der 0.92.
Die 0.91 hat er irgendwie kaputtgemacht. Das hat schon ohne Zmax funktioniert.

Ich bin auch grad echt am Verzweifeln mit dem Repetier-Zeug. Die 0.91 funktioniert nicht mehr richtig und die 0.92 ist eine ungesicherte Baustelle. Die Laser-Option z.B. habe ich zwar kompilieren können (auch Bug im Konfigurator) aber ich kann sie nirgends einschaltenconfused smiley

Viel Erfolg,
Stefan
Re: Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)
23. November 2015 17:35
First move z-axis, so the z-probe will not hit the bed at any position. Then enter “G32 Sx” where x is:

0 : if you have no z-max endstop. You need to run this procedure after enabling the printer or before every print.

1: To auto level the bed and compute the maximum z height of your print area. Requires a z-max endstop. After that, you can even use home and you keep leveled. Leveling if lost on printer restart.

2: Like 1, but leveling data is stored in eeprom (requires activated eeprom). That way you need only to level once and after homing you leveling is active and correct. Repeat only if you changed bed or extruder.

Z-Max ist Z-Max also oben. Wenn man einen hat misst er die Strecke von Z-Max zum Bett. Wenn man einen Reset macht fährt er nach oben und weiß dadurch wie das Bett steht.

Ohne Z-Max muss man um den 0 Punkt zu finden wieder Proben.
Re: Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)
23. November 2015 17:39
Quote
Alterego
Hi Wolfgang,
- hast du Autolevel auch im EEprom eingeschaltet?
- Der normale Z-Endstop muss ausgeschaltet sein (ist bei mir zumindest so; ich lege den Sensor aber auch auf diesen PIN)
- beim PRotos brauchst du den G29 überhaupt nicht (hast du oben geschrieben).

hast du das schon gelesen: [www.repetier.com]
Also die Anleitung hast du hoffentlich schon mal gelesen - aber das was da drüber steht auch?angry smiley


OK, Ergänzung nach deinem letzten Post:
Probiers mit der 0.92.
Die 0.91 hat er irgendwie kaputtgemacht. Das hat schon ohne Zmax funktioniert.

Ich bin auch grad echt am Verzweifeln mit dem Repetier-Zeug. Die 0.91 funktioniert nicht mehr richtig und die 0.92 ist eine ungesicherte Baustelle. Die Laser-Option z.B. habe ich zwar kompilieren können (auch Bug im Konfigurator) aber ich kann sie nirgends einschaltenconfused smiley

Viel Erfolg,
Stefan

Here G1/G2/G3 moves have laser enabled and G0 moves have it disables.
Re: Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)
23. November 2015 17:41
Ja genau. Der Z-Max macht Sinn, wenn man die Probe speichert und nicht jedesmal neu misst. Aber ansonsten ist er überflüssig.

Repetier scheint es aber so zu wollen. Das liest man auch in seinem Forum.

Bei der 0.92 hat es bei mir zumindest ncoh ohne Z-Max funktoniert.
Re: Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)
23. November 2015 17:49
Funktioniert auch ohne Z-Max, richtig. Nur nach jeder Strom Trennung muss getastet werden. Auch mit eeprom.
Und man sollte mindestens 0.92 haben für Z-Probe.

Babystepping ist aktuell echt launisch und will sehr langsam benutzt werden.
Re: Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)
23. November 2015 18:04
Hallo Jetiman,

jetzt gerät hier alles etwas durcheinander winking smiley

Erst zum Thema:
Autoleveling habe ich immer vor jedem Druck gemacht. Dauert ein paar Sekunden - was spricht da dagegen?
Es hat bei mir auch schon mal mit der 0.91 funktioniert ohne Z-Max. Jetzt geht es nicht mehr und ich lege da auch grade keinen Wert drauf.

Wolfgang sollte es halt mal mit der 0.92 probieren...

Babystepping: Schön, dass ich da mal eine Bestätigung bekomme! ich kann manchmal ein paar wenige Ticks am Encoder drehen, dann stürzt das Board so böse ab, dass ich es komplett vom Strom trennen muss. Meine Vermutung: da ist an der Display- bzw. Encoder-Steuerung was faul.

Laser: Es gibt ja einen Default printer mode. Bloß wie schalte ich von diesem in den Laser-Mode? Hintergrund: Ich stecke den Laser einfach anstelle des Drucklüfters an. Ich werde das wohl weiter manuell machen, da weiß ich was passiert...

N'amd,
Stefan
Re: Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)
24. November 2015 14:36
Also für mich macht es so langsam den Eindruck als ob das auto bed leveling mit repetier völlig für den Arsch ist ... bei allem Respekt!
Ein Z-Max ist in jedem Fall absolut überlüssig wenn es um darum geht die Neigung der Druckfläche zu ermitteln!
1. Tastet man vor jedem Druck die drei Punkte an so braucht man das Z-Max nicht!

2. Ist die Neigung im Eeprom gespeichert, so genügt es einen Punkt auf der Fläche zu tasten und schon kann man die Tiefe für jeden beliebigen Punkt
errechnen, ebenso als hätte man die drei Punkte angetastet. Z-Max ist auch dafür überlüssig.

Ich weiß nicht so recht ob ich auf eine andere Repetierversion wechseln soll wenn hier schon bekannt ist, dass die andere Bugs besitzt!
Babystepping habe ich nur ganz am Anfang gebraucht, dann das letzte halbe Jahr nicht mehr.
So lange ich PLA druckte hat es bei jedem Druck ganz sauber gepasst. Ich habe fast den Eindruck, dass sich das Druckbett nach den höheren Temperaturen beim ABS-Druck verbogen hat und nun hab ich es beim letzten Druck erst mal wieder eingesetzt.

Quote
- hast du Autolevel auch im EEprom eingeschaltet?
Wo kann man das aktivieren? Bisher hab ich es nur in der Firmware eingestellt.

Quote
- Der normale Z-Endstop muss ausgeschaltet sein (ist bei mir zumindest so; ich lege den Sensor aber auch auf diesen PIN)
Kann ich austesten"

Quote
- beim PRotos brauchst du den G29 überhaupt nicht (hast du oben geschrieben).
Warum brauch ich den nicht? Ich dacht erst G28 und dann G29?

Vielleicht wäre ein Wechsel zu Marlin doch langfristig die bessere Lösung?

LG

Wolfgang
Re: Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)
24. November 2015 15:55
Hi,
Quote
derschutzhund
2. Ist die Neigung im Eeprom gespeichert, so genügt es einen Punkt auf der Fläche zu tasten und schon kann man die Tiefe für jeden beliebigen Punkt
errechnen, ebenso als hätte man die drei Punkte angetastet. Z-Max ist auch dafür überlüssig.
Der Meinung bin ich auch!

Quote

Quote
- hast du Autolevel auch im EEprom eingeschaltet?
Wo kann man das aktivieren? Bisher hab ich es nur in der Firmware eingestellt.
Im Repetierhost in den EEprom Settings.

Quote

Quote
- Der normale Z-Endstop muss ausgeschaltet sein (ist bei mir zumindest so; ich lege den Sensor aber auch auf diesen PIN)
Kann ich austesten"
Repetier schreibt irgendwo, dass man die Endstop-PINs überhaupt nicht nehmen soll...

Quote

Quote
- beim PRotos brauchst du den G29 überhaupt nicht (hast du oben geschrieben).
Warum brauch ich den nicht? Ich dacht erst G28 und dann G29?
Lies dir bitte die Anleitung durch, die ich oben verlinkt habe. Du verwechselt das mit Marlin.

Quote

Vielleicht wäre ein Wechsel zu Marlin doch langfristig die bessere Lösung?
Kann gut sein.
Ich setze große Hoffnungen in die geplante Firmware von Glatzemann. Außerdem sind ja mittlerweile auch eine ganze Menge Alternativen in der Mache.

Gruß,
Stefan
Re: Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)
24. November 2015 16:37
Quote
Lies dir bitte die Anleitung durch, die ich oben verlinkt habe. Du verwechselt das mit Marlin.
Hab ich natürlich gemacht.

Vielleicht versuche ich morgen mal wie das Druckergebnis ist wenn ich in der Mitte der Druckfläche antaste.
Das sollte beim Protos genügen und für die beiden Neubauten, mit der größeren Druckfläche gehe ich gleich auf Marlin4due.

Quote
Ich setze große Hoffnungen in die geplante Firmware von Glatzemann. Außerdem sind ja mittlerweile auch eine ganze Menge Alternativen in der Mache.
So eine Firmware für einen Drucker zu schreiben die zuverlässig läuft und alle aktuellen Funktionen besitzt dürfte nicht so leicht zu erledigen sein.
Der Teufel steckt im Detail!
Vor vielen Jahren hab ich CNC-Software beruflich entwickelt und weiß wovon ich spreche.
Immer wieder von Vorne neu anzufangen macht nicht immer Sinn.
Bei einigen aktuellen Entwicklungen habe ich den Eindruck, dass einfach der Schwerpunkt falsch gelegt wird.
Da geht es dann eher um die Anbindung an eine Cloud oder die Fernsteuerung an Statt erst mal Grundfunktionen vernünftig durchzuprogrammieren.

LG

Wolfgang
Re: Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)
24. November 2015 16:45
Moin moin aus HU.
Bei mir ist der Z Endstop-Pin eingeschaltet, jedoch in der config als z Endstopp ausgeschaltet und nur für das ABL aktive. Hat mir Wurstnase so eingerichtet und das klappt prima. Meine max.Endstops sind alle aus und nur die max Soft-Endstops aktive.
Bevor ich den Drucker betreibe, mache ich erst einmal ein ABL. Damit steht dann auch Xmin fest und ich brauche den X-Endstop nicht mehr. Dafür habe ich im Repetier Host eine Routine in einem Skript
abgelegt, dass ich vor dem Drucken einmalig ausführe. Die Werte bleiben solange aktive, bis ich das Rumba-Board resette.


Liebe Grüße aus Kaltenkirchen.
Frithjof
Meine Seite
[www.facebook.com]
Re: Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)
24. November 2015 16:49
So wär es ideal!
Welche Repetierversion verwendest du?

LG

Wolfgang
Re: Auto bed leveling (kapazitiv) + E3D Hotend nachgerüstet (RepRapPro Mendel)
24. November 2015 17:00
Repetier Host V1.6.0, Repetier FW 0.92.2

Hier das Sript
G28 X0 Y0; // Homing nur für X und Y
G1 Z10; // wenn er zu nahe am Bett steht funktioniert z-Probe nicht
G32 S0 ; // Autobedleveling
G1 X0 Y0 F9000; // zurück nach Hause

pins.h
Configuration.h

Das Abl mache ich natürlich erst, wenn HB und HE heiss sind.
Bei kalten Komponenten reicht es aber, damit man die Achsen verfahren kann.

Ich hatte auch erst ein Verständnisproblem mit dem Z Endstop. Nach dem mir aber Nico erklärt hatte, dass man den ja nicht braucht, da ja durch das ABL der Z MIN Wert feststeht, war mir alles klar. Bei Düsenwechsel oder anderen Bastelarbeiten stelle ich im EEPROM den ZProbe hight Wert neu ein und dann passt es. Ich gebe aber zu, dass ich mich an den Wert in 0,1mm Schritten herantaste. Das dauert dann eine Minute oder so bis zur nächsten Bastelei.

1-mal bearbeitet. Zuletzt am 24.11.15 17:08.


Liebe Grüße aus Kaltenkirchen.
Frithjof
Meine Seite
[www.facebook.com]
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen